Solved: 8 Years, 2 Months, 3 Weeks ago Coding assistance needed
#1
Solved: 8 Years, 2 Months, 3 Weeks ago
Alright, this isn't a huuuuge hurry, I just need a fresh set of eyes and a clearer mind to help me out with this. I've been working on color coding mybb's 1.8 for the last few hours. I know a while but trust me it's faster than I did the first time around. lol. Anyway. I seem to have made a goof. Sad

As I said I just need a fresh pair of eyes, because my brain is slightly fried right now.... Ok so here's my problem... Visual first...

[Image: Capture_zps57790030.png]

Ok... Both the squared off area and the circled area are on the same code section in the theme... However.... Normally the squared off section is on the left (as they both are) and the circled section is on the right..... Somehow I got the bottom that's supposed to be on the right, hooked to the left. Sad

I did try to fix it. figuring "Hey I'll just move the whole thing to the right... Right? Yeah... That doesn't work because then the squared off part looks really bad. Sad So um... Without having to undo EVERYTHING I did this afternoon.. Anyone know a way I can fix this mess up?
Why do we ever bother to learn anything? Nothing ever seems to work the same way twice anyway....  Huh
Reply
#2
Solved: 8 Years, 2 Months, 3 Weeks ago
your forum's current theme should show debug information at the right side. are you referring to another theme ?

Edit: you can add text-align: right; for the debug div id in the global.css
Reply
#3
Solved: 8 Years, 2 Months, 3 Weeks ago
No. I'm just recoloring the base mybb theme. Haven't gotten the hang of those off branch themes yet.

Debug.... Ok I'll take a look. Thank you. Smile

EDIT: Text-align and float are both right. Sad

postbit_quote
#debug {
	float: right;
	text-align: right;
	margin-top: 20px;
	font-size: 11px;
Why do we ever bother to learn anything? Nothing ever seems to work the same way twice anyway....  Huh
Reply
#4
Solved: 8 Years, 2 Months, 3 Weeks ago
Can you post a few lines higher of your CSS? postbit_quote shouldn't be where it's at.
Reply
#5
Solved: 8 Years, 2 Months, 3 Weeks ago
Well that could explain it.... Did I somehow move things around I shouldn't have? Well... My blonde roots are certainly showing with this project. lol.

#footer .lower a:hover,
#footer .lower a:active {
	color: goldenrod;
	text-decoration: underline;
	font-weight: bold;
}

#footer .lower #current_time {
	float: right;
	color: darkred;
}
postbit_quote
#debug {
	float: right;
	text-align: right;
	margin-top: 20px;
	font-size: 11px;
}

.scaleimages img {
	max-width: 100%;
}

.forum_status {
	height: 30px;
	width: 30px;
	background: url(images/forum_icon_sprite.png) no-repeat 0 0;
	display: inline-block;

Lines 279 - 306 (probably could have shared line numbers with the last one may have helped.)

EDIT: Found the problem.... Somehow I moved that piece (that shouldn't be there) to that slot... Thank you.
Why do we ever bother to learn anything? Nothing ever seems to work the same way twice anyway....  Huh
Reply
#6
Solved: 8 Years, 2 Months, 3 Weeks ago
remove postbit_quote
Reply
#7
Solved: 8 Years, 2 Months, 3 Weeks ago
It made all the difference in the world. Thank you, you guys. I appreciate it. I knew I just needed a set of fresh eyes. Smile
Why do we ever bother to learn anything? Nothing ever seems to work the same way twice anyway....  Huh
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)