Thread Rating:
  • 10 Vote(s) - 3.2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.8] Recent Threads On Index [Updated 02-12-19]
(12-31-2018, 10:59 AM)NoRules Wrote: Hi,

when I try to install your plugin, I've found a problem in the templates.php file.

In line 54 where it says:
$new_template['recentthread_avatar'] = '<a href="{$mybb->settings[\'bburl\']}/member.php?action=profile&uid={$thread[\'uid\']}"><img src="{$avatarurl}" {$dimensions} alt="{$avatarurl}" onerror="this.src='/images/default_avatar.png';"/></a>';

It must be:
$new_template['recentthread_avatar'] = '<a href="{$mybb->settings[\'bburl\']}/member.php?action=profile&uid={$thread[\'uid\']}"><img src="{$avatarurl}" {$dimensions} alt="{$avatarurl}" onerror="this.src=\'/images/default_avatar.png\';"/></a>';

Nice work  Wink

I made the update on Github.  Thanks.
Reply
I'd like a couple people to try the latest code on Github and see if there are any errors. Pending no errors, the new build will get posted to the extend section.
Reply
I have the newest build on the extend section now. For those wondering why it was marked vulnerable before, it was a mistake. It wasn't spotted that I use forumselect for which forums to ignore and use that directly in a query. PHP 7.3 is supported for those who are already using that. There is no update script that needs to be run because no database changes were done. Some minor bug fixes were also solved in this release.
Reply
(02-12-2019, 05:32 PM)dragonexpert Wrote: I have the newest build on the extend section now.  For those wondering why it was marked vulnerable before, it was a mistake.  It wasn't spotted that I use forumselect for which forums to ignore and use that directly in a query.  PHP 7.3 is supported for those who are already using that.  There is no update script that needs to be run because no database changes were done.  Some minor bug fixes were also solved in this release.

You might want to update the thread title to the latest date of the plugin update.
I'm Serpius and You're Not    ¯\_(ツ)_/¯
[Image: y3xr3cj5]
Reply
Fixed.
Reply
Great news, thank you
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
I discovered a noncritical bug which it doesn't show a thread as locked if it is locked. If you wish to patch it before my next build, you'll want to go to this line: https://github.com/dragonexpert/recentth...s.php#L268.

Change $folder .= "lock" to $folder .= "close".

The next build has some improvements. Screenshots will come after work tomorrow.
Reply
not working
Reply
What is not working? I have been using this plugin for over 2 years, without any issue Smile
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
@Sinanus: You aren't giving any information that can help solve the problem.  Where are problems encountered?  Have you checked the plugin settings?  Did you check the index template for {$recentthreadtable}?

Edit: Added a screenshot that has a preview of the next version.  Mass moderation is a feature that will be available to all global moderators.  I currently have open, close, approve, unapprove, lock, unlock, stick, unstick, and soft delete threads as options.  I will look into restoring threads and custom tools depending on the difficulty of implementing.

   
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)