Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved Odd Bug 1.8 Post New Thread Button
#1
Not Solved
This just started today and I have checked and rechecked all my user settings and forum permissions nothing has changed since yesterday. All my new users that have registered from today forward cannot see the post new thread button in my first forum. All of my settings and permissions seem to be right and they haven't changed. I elevated some test users all the way up to Administrator and they still can't see the post new thread button. However lower level users that registered the day before can.
I can't make any sense of it.

Using 1.8 default theme.

It is both the upper and lower button that don't show up like they don't have permission to post even though that is not the case.
Reply
#2
Not Solved
What is your forum link?
Reply
#3
Not Solved
(09-23-2014, 05:30 AM)Shiblee Wrote: What is your forum link?
NSFW
http://www.eroticinventions.com/


I have been playing around with it and I discovered the same problem in other forums besides the first one.  I have my forum set up where registered/verified users have to be upgraded to a custom user group before they can start new threads to cut down on spam.  When I turn back the ability for my registered users to start new threads all my new users no matter the group can start new threads.  However, if I turn that off no newly registered and verified users including Moderators, and Administrators can see the new thread button even though those groups all have their permissions set on being able to start a new thread.  

I am also noticing  since 1.8 all newly registered users get their default language set to the first one in the drop down menu despite the forums default language being set up as English. This makes it hard for them to do anything because they can't decipher where to go and change their default language.
Reply
#4
Not Solved
there is some misconfiguration - needs to be checked



And you should remove unnecessary language packs

it appears that you have installed MyBB forum from web host panel
and many language packs are installed. it gives many problems and
I suggest to remove the unnecessary language packs

language packs are located at ./inc/languages folder

language pack consists of a php file with language name and a folder
with that language name (eg. deutch_eu.php file & deutch_eu folder)

unwanted language pack can be removed by deleting both the file and
the folder with the specific language name

most probably you need just a single language or a couple of languages for the forum ..
Reply
#5
Not Solved
Thanks. I fixed the language problem by deleting the first four packs which left English as the first one.

As to the other problem it seems to be a bug related to the forum permission system. If you have a custom user group your permissions end up being messed up for every other user group.
Reply
#6
Not Solved
the permission system needs to be investigated ..

regarding the language packs, suggestion is to remove all the unnecessary languages!
keep only the languages your forum really needs
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)