Not Solved [How To?] set the text editor
#1
Not Solved
Hello My name is Muhammad Waqas and my forum is www.rawalpindiforum.pk.
I  wants to discuss that when I post on my forum as admin and make addition in text or insert videos, pictures in the editor it appears immediately in the editor as you can see below:
[Image: 9361731_orig.png]

But when any user post on the forum as a user, the above changes would not appears in the editor, these appears after publishing the post or thread as you can see below:
[Image: 7889544.png?683]

Please guide me that how do I solve this problem?
I am waiting for your reply
Regards
Reply
#2
Not Solved
Hey Muhammad, I am not entirely sure if I understood your problem correctly but from what I can tell, the issue is whether the editor is in source mode or not. This can be changed in your User CP > Edit Options > Uncheck "Put the editor in source mode by default" to have it look like in the admin-account-screenshot.

As far as I know, there is no option in ACP to globally override the user-settings. Therefore, in order to have all users use the wysiwyg-mode is to run the following SQL-query:
UPDATE `mybb_users` SET `sourceeditor` = '0'

Hope this helps.
Reply
#3
Not Solved
(2014-09-29, 11:51 AM)chriki Wrote: Hey Muhammad, I am not entirely sure if I understood your problem correctly but from what I can tell, the issue is whether the editor is in source mode or not. This can be changed in your User CP > Edit Options > Uncheck "Put the editor in source mode by default" to have it look like in the admin-account-screenshot.

As far as I know, there is no option in ACP to globally override the user-settings. Therefore, in order to have all users use the wysiwyg-mode is to run the following SQL-query:
UPDATE `mybb_users` SET `sourceeditor` = '0'

Hope this helps.

Plz guide me where do I put this code?
Reply
#4
Not Solved
^ see this guidance => running SQL queries
Reply
#5
Not Solved
(2014-09-29, 11:51 AM)chriki Wrote: Hey Muhammad, I am not entirely sure if I understood your problem correctly but from what I can tell, the issue is whether the editor is in source mode or not. This can be changed in your User CP > Edit Options > Uncheck "Put the editor in source mode by default" to have it look like in the admin-account-screenshot.

As far as I know, there is no option in ACP to globally override the user-settings. Therefore, in order to have all users use the wysiwyg-mode is to run the following SQL-query:
UPDATE `mybb_users` SET `sourceeditor` = '0'

Hope this helps.

Plz guide me where do I put this code?
Reply
#6
Not Solved
^ have you seen the suggested thread ? please see it once again.
you should be having a database manager at web host control panel. there you can use such SQL queries.
Reply
#7
Not Solved
I had seen the phpMyAdmin option but I am confused. I am using cpanel. Please refer me to a tutorial where I can get help
Reply
#8
Not Solved
http://community.mybb.com/thread-4720.html
http://www.siteground.com/tutorials/phpm..._query.htm
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)