[Rejected] Avatar bug - edit a user
#11
(2014-12-15, 11:11 PM)Eldenroot Wrote: We should reject this issue - it is caused by plugin from mybb 1.6

@ArchPrime - please, could you try another link? I fixed this issue - just uninstal old plugin completely or edit every user without profile

Manually editing hundreds of users without a default avatar is not a great or workable idea.  Neither is uninstalling the plugin, as then there would be no way to retroactively apply a default image to existing profiles.

The plugin still works perfectly and fills a gap in core functionality of myBB.  The image is still found and displays correctly despite the error message showing in AdminCP.  It seems to me the issue is exposing an underlying bug rather than actually caused by the plugin.
Paul King
MyBB version: 1.8.21
Forum: www.nzarchitecture.net.nz
Webpage: www.prime.net.nz
Reply
#12
(2014-12-16, 01:01 AM)ArchPrime Wrote: as then there would be no way to retroactively apply a default image to existing profiles.

The plugin still works perfectly and fills a gap in core functionality of myBB.

You can clearly see in your post that default avatars are applied in the 1.8 core by the format_avatar() funcion and there is no need for a plugin..
Reply
#13
My post clearly shows the avatar placed there by the plugin prior to upgrading to 1.8.3. 
Has 1.8 added new functionality that fully replaces the plugin? i.e. that would allow me to globally replace all current default or missing  avatars of existing users with another avatar of my choosing?
Paul King
MyBB version: 1.8.21
Forum: www.nzarchitecture.net.nz
Webpage: www.prime.net.nz
Reply
#14
Recap: ArchPrime has upgraded from 1.6 to 1.8.3 . In 1.6 there was no default avatar so a plugin was used. In 1.8 a default avatar is part of the core.

Now the 1.6 plugin is causing issues in the ACP. That plugin is defunct as it is part of the 1.8 core to have a default avatar.

ArchPrime - make a backup and uninstall that plugin. The standard mybb 1.8 default avatar will then kick in. If it doesnt - upload backup.

Mybb1.8 features : http://blog.mybb.com/2014/09/01/mybb-1-8-released/
Random Fish and Sims Maniac
MY PLUGINS
Help MyBBSupport help you - remember to mark your threads as solved


Reply
#15
Thanks LeeFish.  That worked.

Doesn't seem to be in the 'images/avatars' folder but I presume somewhere there will be an image I can replace if I want to globally impose a different style of default of avatar on everyone (new and existing users)?


Cheers
Paul
Paul King
MyBB version: 1.8.21
Forum: www.nzarchitecture.net.nz
Webpage: www.prime.net.nz
Reply
#16
The default avatar is in the images folder - default_avatar.png

What you can also do - and this is nice - you can allow users to use their gravatar.

If they don't have a gravatar they are easy to get and what is clever is that the avatar is tied to their email address.

So if they comment on blogs and things outside MyBB then they will also have an avatar showing on blog posts that matches the one they use on your forum :


www.gravatar.com
Random Fish and Sims Maniac
MY PLUGINS
Help MyBBSupport help you - remember to mark your threads as solved


Reply
#17
(2014-12-16, 08:55 AM)ArchPrime Wrote: Doesn't seem to be in the 'images/avatars' folder but I presume somewhere there will be an image I can replace if I want to globally impose a different style of default of avatar on everyone (new and existing users)?

ACP -> Configuration ->Profile Options -> Default User Avatar / Default Avatar Dimensions

Anyways, I'll mark this as pushed since it should probably be fixed in the issue I linked in my previous post: http://community.mybb.com/thread-161695-...pid1121546
Reply
#18
So I presume this is rejected. I moved it.
Reply
#19
(2014-12-16, 01:54 PM)Destroy666 Wrote:
(2014-12-16, 08:55 AM)ArchPrime Wrote: Doesn't seem to be in the 'images/avatars' folder but I presume somewhere there will be an image I can replace if I want to globally impose a different style of default of avatar on everyone (new and existing users)?

ACP -> Configuration ->Profile Options -> Default User Avatar / Default Avatar Dimensions

Anyways, I'll mark this as pushed since it should probably be fixed in the issue I linked in my previous post: http://community.mybb.com/thread-161695-...pid1121546

When nominating the default avatar via path in ACP -> Configuration ->Profile Options -> Default User Avatar, nothing is found (even though a valid avatar image is at ../images/avatars/default.jpg), and when nominating via url http://www.nzarchitecture.net.nz/images/...efault.jpg, nothing is found because in the ACP -> Edit User -> Avatars window, a path prefix '../' is automatically added to the url.  When the auto prefix is manually deleted, it works

Does this suggest the '../' prefix automatically being added to avatar path/url is part of the problem?

Could/should we perhaps have constancy of terminology between ACP -> Configuration ->Profile Options -> Default User Avatar and ACP -> Edit User -> Avatars ?  It is hard to know whether we should we be supplying a path or an url - or is it intended that these be interchangeable?  (most users won't know any paths to avatar images, while most admins won't want to use an url when a perfectly good local path exists)

I further note that the new 1.8 default avatar approach does NOT seem to provide a default avatar for all existing users who lack avatars.  It only seems to help new sign ups.  The whole point of the old plugin was to deal with existing users with no avatar.


   

I think maybe the answer is not to check for a valid avatar url when saving other user profile changes made in ACP.

Quite rightly, a user editing their own profile would want to use an url to initially supply a new image, after which however (once the image has been copied to the local images /avatars directory) subsequent edits to the profile (particularly ones not related to avatar) should not be upset by the fact that the image is now referenced by a local path, not an url.
Paul King
MyBB version: 1.8.21
Forum: www.nzarchitecture.net.nz
Webpage: www.prime.net.nz
Reply
#20
Hello there. Did you find a solution?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)