Jump to the post that solved this thread.
Solved: 6 Years, 8 Months, 1 Week ago Can't access my forums
#1
Solved: 6 Years, 8 Months, 1 Week ago
Hi there! Just created forums on my myBB installation. But I can't access or post in any of them.
When I click on a forum say "Announcement" it keeps redirecting me to the homepage.


Can you help please?
No. the site is not lock.

The forums' url for your refs: http://goo.gl/3K1ZCA

Thanks in advance.
Reply
#2
Solved: 6 Years, 8 Months, 1 Week ago
your files server has htaccess.txt file. rename it as .htaccess (there is a dot as prefix)

or

admin panel >> configuration >> settings >> Server and Optimization Options
--> Enable search engine friendly URLs? --> select disabled & save settings
Reply
#3
Solved: 6 Years, 8 Months, 1 Week ago
Hi! Thanks works like a charm.
BTW why does this setting affects the forum behavior?
Reply
#4
Solved: 6 Years, 8 Months, 1 Week ago
if you Enable the "search engine friendly URLs" then you need a .htaccess (not htaccess.txt) file in the root folder, for the urls to work, else you will face this issue...
We can't help everyone, but everyone can help someone - Ronald Reagan
Did you know? Your question has already been answered. But you haven't searched it yet.
Don’t  Forget to “Mark as Solved” after the fix
Reply
#5
Solved: 6 Years, 8 Months, 1 Week ago
Edit: delayed response

MyBB has search engine friendly (SEF) url facility for the search engine optimization (SEO). it requires url rewrite rules.
those rules are provided through .htaccess file (for apache server). the related setting is set to automatic by default
if the setting is changed to enabled then url rewrite rules must be available so that SEF URLs work.

this MyBB support community uses SEF URLs. however many users disable it and use Google SEO plugin for the SEO
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)