Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 5 Years, 4 Months ago MYBB 1.83 IP Change Problem
Solved: 5 Years, 4 Months ago
Hi everyone,

I did search for this prior to posting both on MyBB and Google.

I decided to change my VPS and IP and reinstall Centos 6.6 after finding base64.inject.unclassified on a daily scan run.  I deleted it but it reappeared the following day (have now identified the source and it was not related to MYBB or a plugin).  Although the hack did not compromise my server it would have affected potential windows users when accessing my site and also failed Google Safe Browsing.

Prior to deleting my old VPS I ran a complete backup of the domain with Virtualmin.  I restored the backup on my fresh VPS.  It installed without errors and I was able to access the back-end without problem.  Everything appears to be functioning correctly.

The front-end is giving me Error 45 saying the cache needs write permissions.  All the directory and file permissions restored correctly.  My server is currently only accessible by IP as setting up and testing MyBB prior to going live).

Is turning BIND on and pointing domain at IP with domain hoster the only way to correct this (ie accessing by domain name rather than IP)?

Any advice would be greatly appreciated.



Problem solved. I downloaded the cache directory then deleted it. I created a new cache directory which gave me the front-end without formatting. I uploaded the theme directory (from the downloaded cache folder) and all is now working fine.
Solved: 5 Years, 4 Months ago

Are your config files rebound to the IP address? They may be accessing instead of ipaddress/cache/

If you don't want to edit your config files, then yes, you'd need to point your domains A records at the IP address to have it work properly.
Solved: 5 Years, 4 Months ago
Thanks for the advice. You are correct. I needed to update the IP address in my config settings. I have restored another Virtualmin backup this week to test. It restored without incident. I have server snapshots in case the restore created problems (website not live yet).


Forum Jump:

Users browsing this thread: 1 Guest(s)