Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.8] Guest Warn - 4.0
#1
[Image: preview_24758_1418070552_0660c582b4e8893...51b7ff.png]

Hello guys! One of the most popular and downloaded plugin for MyBB 1.6.x returns for MyBB 1.8.x stronger than ever! Yes, we are talking about Guest Warn at his fourth version! 

Description

Show an elegant warn for all guest of your forum.

Features 

  • Add an elegant warn in all pages of your forum for guests.
  • Removable warning.
  • jQuery effects.
  • Message editable.
  • Template editable.
  • CSS editable.
  • What is changed from the 3rd version?
What is changed from the 3rd version?

  • Plugin rewritten from 0 for MyBB 1.8.x
  • You can choose what group can see the warn.
  • You can choose how many time you have to wait until the warn reappears.
  • You can edit the warn by global templates.
  • You can edit all CSS properties by theme manager of your ACP.
  • PHP structure improved.
  • Most stable version.
Installation

Copy the file "guestwarn.php" and "pluginlibrary.php" into "your_forum_folder/inc/plugins", go to PCA and activate it. And.... Done!!!

Update from 3.0 

WARING: this is a major release, the plugin will remove all old settings. Please, make a backup copy of your old files and copy your warn message before to update.
Pay attention, 3rd version of this plugin is written for MyBB 1.6.x. It's unlikely that you have the 3rd version on MyBB 1.8.x unless you edited the compatibility from "avvisospiti.php".

Go to your Administration Control Panel >> Plugins and deactivate the old plugin.

Go to "your_forum_folder/inc/plugins" and delete "avvisospiti.php", go to "your_forum_folder/images" and delete:
  • -.png
  • +.png
Go into your forum folder and delete "get-cookie.php".

Now you have to install the plugin following the "Installation" guide.


Next version?

Stay tuned [Image: biggrin.gif]




[Image: preview_24758_1418070552_0660c582b4e8893...51b7ff.png]


[Image: preview_24758_1418070568_b69c69e261bc1bf...23d27e.png]


[Image: preview_24758_1418070647_3ef2fcd43b2fdf4...dabd96.png]


[Image: preview_24758_1418070657_9bf6b2c760e8e4e...4edfe4.png]
Reply
#2
I cannot activate it - error - you need plugin library v9 or newer - I use v12 Smile
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#3
(2014-12-09, 08:03 PM)Eldenroot Wrote: I cannot activate it - error - you need plugin library v9 or newer - I use v12 Smile

Thank you very much for your support. Please, could you report the bug in the bug tracker?

Anyway it is very strange because the plugin uses "plugin library v12"... Could you open your pluginlibrary.php file and compare with the pluginlibrary.php of my plugin?
Reply
#4
Very nice! Thanks for this mate
Reply
#5
I tried to copy your pluginlibrary - same problem
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#6
(2014-12-09, 08:50 PM)Eldenroot Wrote: I tried to copy your pluginlibrary - same problem

Well, I don't know why it not works. I have to wait other people with the same problem. If you want to use the plugin, you can "hack" this problem removing:


if (!file_exists(PLUGINLIBRARY)) {
    flash_message($lang->myalerts_pluginlibrary_missing, "error");
    admin_redirect("index.php?module=config-plugins");
    }

from "guestwarn.php"!
Reply
#7
I have already made this change Smile

still I cannot activate it...
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#8
This activated for me and works well good.
Reply
#9
I still cannot activate this plugin Sad
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#10
(2014-12-13, 10:23 AM)Eldenroot Wrote: I still cannot activate this plugin Sad

What is the error?
My plugins:


[MyBB 1.8] Guest Warn 4.0
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)