Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 4 Years, 10 Months, 4 Weeks ago Javascript/inline moderation not working?
#11
Solved: 4 Years, 10 Months, 4 Weeks ago
(12-15-2014, 07:22 PM)Johnny S Wrote: In your installed / activated plugins (on plugins page) do you have one that relies on javascript (some 1.6 plugins like "fit on page", "thank you / like system", myalerts (prototype version), few shoutboxes are relying on prototype library [that was default in 1.6]) ?

I had mystatus and Myalerts installed. I already uninstalled mystatus, and I justuninstalled Myalerts. No change.

(12-15-2014, 07:32 PM)Leefish Wrote: I have to confess I am stumped. Looking at that you either dont have all the js files on the server or they are not correctly linked in the templates.

If you are having these issues with the default theme then the first thing is to disable all plugins and test on the default theme. If the default theme then has no issues then its a plugin. If you are still having issues on the default theme please ensure you have all the js files.

I'm going to have to use this as a last resort, as I already closed the website from the beta testers once last night to implement an anti-proxy system. I doubt they will take kindly to me closing it a second time.

I went ahead and reverted the jscripts file to its original state. Regular JS works now, but still not inline moderation.

Spammers areattacking my website. Yay.
Reply
#12
Solved: 4 Years, 10 Months, 4 Weeks ago
^ looks like you are using MyAlerts coded for MyBB 1.6.x - though it is deactivated its js file affects
edit myalerts.js file and remove the first line of code - it is a noconflict statement
Reply
#13
Solved: 4 Years, 10 Months, 4 Weeks ago
That did not work. After trying that, I uninstalled the jscripts folder, and reinstalled it. So now there are no plugin js files whatsoever. Which leads me to believe the inline moderation errors have nothing to do with javascript.

When I try to use inline moderation using the seection boxes, the web console adds this every time I check oneb of the checkboxes:

ReferenceError: $ is not defined
Reply
#14
Solved: 4 Years, 10 Months, 4 Weeks ago
^ hmm., forum url is required for basic checking
temporary moderator account (admin account is better) might be required to check what is actually happening

you can post the details in Private Inquiries section so that only staff here can view
Reply
#15
Solved: 4 Years, 10 Months, 4 Weeks ago
http://community.mybb.com/thread-164265.html

This is still unsolved.
Reply
#16
Solved: 4 Years, 10 Months, 4 Weeks ago
This is now solved. Issue was missing js files for the core and missing js files for the theme,
Random Fish and Sims Maniac
MY PLUGINS
Help MyBBSupport help you - remember to mark your threads as solved


Reply
#17
Solved: 4 Years, 10 Months, 4 Weeks ago
Solved. For anybody having the same problem, try deleting the "Jscripts" folder from your server, then uploading the jscripts folder from the latest version of mybb, then e-uploading the files fom the theme you are using.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)