Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 4 Years, 10 Months, 4 Weeks ago [General] MyCode
#1
Solved: 4 Years, 10 Months, 4 Weeks ago
Hello again, I do want to let MyCode download but I have a problem that when you enter bbcode post a picture I do not see!

regular expression:
\[dl\](.*?)\[/dl\]

conversion:
<a href="$1"><img src="images/download.png"></a>

and does not work, please help!
Reply
#2
Solved: 4 Years, 10 Months, 4 Weeks ago
Please give me an example of what you are typing in to post the picture.

Like this:
[bob]BOB[/bob]
Reply
#3
Solved: 4 Years, 10 Months, 4 Weeks ago
[dl]link dl[/dl]
Reply
#4
Solved: 4 Years, 10 Months, 4 Weeks ago
1. You're not closing the img tag properly, it should be:
<img src="images/download.png" />
2. img requires alt attribute, so it should be:
<img src="images/download.png" alt="" />

But I doubt that will fix it. If it doesn't show a link to a thread in which you use the BBCode.
Reply
#5
Solved: 4 Years, 10 Months, 4 Weeks ago
Still not working.
Reply
#6
Solved: 4 Years, 10 Months, 4 Weeks ago
Maybe you have a whitespace before \[dl\](.*?)\[/dl\] in textarea.
Greetings Sven (ps: Sorry for my bad english!!)

My plugins - [email protected]
Reply
#7
Solved: 4 Years, 10 Months, 4 Weeks ago
(12-18-2014, 08:21 PM)Szibiasty Wrote: Still not working.

(12-18-2014, 07:54 PM)Destroy666 Wrote: But I doubt that will fix it. If it doesn't show a link to a thread in which you use the BBCode.
Reply
#8
Solved: 4 Years, 10 Months, 4 Weeks ago
I do not understand :/
Reply
#9
Solved: 4 Years, 10 Months, 4 Weeks ago
Have you checked this??

I guess you have a space at beginning of regular expression.

   
Greetings Sven (ps: Sorry for my bad english!!)

My plugins - [email protected]
Reply
#10
Solved: 4 Years, 10 Months, 4 Weeks ago
Thanks, lol Big Grin //lock
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)