Solved: 6 Years, 7 Months, 1 Week ago Problem with bar in post new reply/thread/pm
#1
Solved: 6 Years, 7 Months, 1 Week ago Exclamation 
I have a problem in my forum - I cannot see bar for text styling (color, size, link, php, etc) in new thread/post reply and new pm

this problem has started when I installed Quick advanced editor plus. Deactivation or uninstall do not fix this issue. I have 2 errors in console:

* Uncaught SyntaxError: Unexpected token ) bbcodes_sceditor.js:555 
*Uncaught ReferenceError: partialmode is not defined


I think this could be related to another plugin which I use in my forum - so maybe it would be nice to delete this "problematic" plugin. I tried to disable all of them, but it doesnt fix it. (on fresh instalation not problem).


I can send you url; username and pw. 


Thank you very much


and Merry Christmass!
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#2
Solved: 6 Years, 7 Months, 1 Week ago
considering that you are using a compatible theme and it was working earlier....

1. did that advanced editor plugin made any core changes

2. did you try removing the plugin files
We can't help everyone, but everyone can help someone - Ronald Reagan
Did you know? Your question has already been answered. But you haven't searched it yet.
Don’t  Forget to “Mark as Solved” after the fix
Reply
#3
Solved: 6 Years, 7 Months, 1 Week ago
I tried to deactivate and uninstall this editor -> problem persists

It works on fresh install -> so I think theremust be a conflict. Text bar works in quict reply and quick edit... BUT not in new post and post reply
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#4
Solved: 6 Years, 7 Months, 1 Week ago
autosave draft requires SCeditor plugin for the quickreply.
at present I've removed autosave draft related code from the codebuttons
template
and you can see that SCeditor bar is functioning normal now.
Reply
#5
Solved: 6 Years, 7 Months, 1 Week ago
OK, now I follow Smile I reverted codebuttons template - sceditor bar works! Thank you!
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#6
Solved: 6 Years, 7 Months, 1 Week ago
(2014-12-24, 06:16 PM).m. Wrote: autosave draft requires SCeditor plugin for the quickreply.
at present I've removed autosave draft related code from the codebuttons
template
and you can see that SCeditor bar is functioning normal now.

autosave draft not required by plugin to work...
in my test forum feature autosave draft disabled and work fine

http://martec.ml/test/

user: test
pass: test123

or you using old version that has issue with canonical link that fixed in last version...
Reply
#7
Solved: 6 Years, 7 Months, 1 Week ago
Of course - I deleted your code for autosave in codebutton template -> sceditor bar is back and visible...
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#8
Solved: 6 Years, 7 Months, 1 Week ago
(2014-12-24, 03:08 PM)Eldenroot Wrote: new thread/post reply and new pm

not related with plugin...
plugin not made any modification in on editor/function/codebutton template etc... of new thread, new replay etc. Only in quick replay and quick edit.

(2014-12-24, 08:17 PM)Eldenroot Wrote: Of course - I deleted your code for autosave in codebutton template -> sceditor bar is back and visible...

STOP said lie...
plugin not made any modification in on editor/function/codebutton template etc... of new thread, new replay etc. Only in quick replay and quick edit.
Reply
#9
Solved: 6 Years, 7 Months, 1 Week ago
ok, then tell me why it is working when I dont use extra code from your tutorial in codebutton template? Wink

Nevermind, now it works fine and I dont wanna change anything

(2014-12-24, 08:19 PM)martec Wrote:
(2014-12-24, 08:17 PM)Eldenroot Wrote: Of course - I deleted your code for autosave in codebutton template -> sceditor bar is back and visible...

STOP said lie...
plugin not made any modification in on editor/function/codebutton template etc... of new thread, new replay etc. Only in quick replay and quick edit.

This is the problem - http://community.mybb.com/thread-156223.html - with this code it is not working
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#10
Solved: 6 Years, 7 Months, 1 Week ago
(2014-12-24, 08:24 PM)Eldenroot Wrote: ok, then tell me why it is working when I dont use extra code from your tutorial in codebutton template? Wink

Nevermind, now it works fine and I dont wanna change anything

i don´t know what you made in codebuton template...
all developers of mybb can check that ( https://github.com/martec/quickadveditor...orplus.php ), my plugin not made any modification in codebutton template.
if has modification in this template, probably because of others plugins that you used/using or unistalled.

This is the problem - http://community.mybb.com/thread-156223.html - with this code it is not working

this isn´t plugin...
tutorial... you need request support in tutorial thread and not in plugin thread.

and i checked now, only work to Quick advanced editor and not to plus because this parte of code
Quick advanced editor {$mybb->settings['quickadveditor_saveamount']} need to change to {$mybb->settings['quickadveditorplus_saveamount']}

{$mybb->settings['quickadveditor_save_lang']} to {$mybb->settings['quickadveditorplus_save_lang']}
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)