Not Solved Forum Default Icon
#1
Not Solved
This user has been denied support. This user has been denied support.
Why i can't change forum default icons.
I tried to change default icons by uploading on, off images to images folder, but still the same.
Any idea how to change those default icons, because i'm using mybb 1.8 and images are 1.6 version.
Reply
#2
Not Solved
MyBB 1.8 uses image sprites and css classes for the status icons.

Post the images you want use here and I'll build for you the matching image sprite.
Reply
#3
Not Solved
since 1.8 uses sprite images, uploading new individual images will not affect anything... 


if you want individual images

after uploading individual images you need to tweak the css a little to see the changes... find this part in global.css of your theme and remove th background for .forum_status and define individual images for each status like .forum_on, .forum_off etc...

.forum_status {
height: 30px;
width: 30px;
background: url(images/forum_icon_sprite.png) no-repeat 0 0;
display: inline-block;
}

.forum_on {
background-position: 0 0;
}

.forum_off {
background-position: 0 -30px;
}

.forum_offlock {
background-position: 0 -60px;
}

.forum_offlink {
background-position: 0 -90px;
}


this is what need to be done....

.forum_status {
    background: url(images/forum_icon_sprite.png) no-repeat 0 0; //REMOVE THIS//
}

.forum_on {
    background-image: url(images/your image path.png); //ADD THIS FOR ALL//
}



if you want a single sprite image

you can upload a sprite image with the name "forum_icon_sprite.png" to the images folder with dimensions of 30px and 120px, with each icon being 30X30px... if you use a different size, change the background-position appropriately for .forum_on, .forum_off etc..

if you dont know how to create a sprite, use any online sprite generators like Site1 or Site2
We can't help everyone, but everyone can help someone - Ronald Reagan
Did you know? Your question has already been answered. But you haven't searched it yet.
Don’t  Forget to “Mark as Solved” after the fix
Reply
#4
Not Solved
This user has been denied support. This user has been denied support.
i fixed because didn't changed the path in theme settings now it's ok .
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)