Jump to the post that solved this thread.
Solved: 6 Years, 8 Months, 1 Week ago Editor format Problem (maybe bug)
#11
Solved: 6 Years, 8 Months, 1 Week ago
The rtl text is placed in an inline span, shouldn't this be in a div?
Regards, Ad Bakker (NL)
Reply
#12
Solved: 6 Years, 8 Months, 1 Week ago
(2015-02-04, 07:28 PM)mujeebdgk Wrote: http://www.aashnai.com/Thread-testing-thread

there are 2 text  
one is normal and other one is RTL mycode

And the RTL works fine if you change the text (for example, add a . at the end and it will be moved to the left). 

To additionally align the text to the right, you would have to place it in a 100% width <div> with text-align: right; attribute.

EDIT: @down, he clearly states that in SCEditor "text is in right side" and he wants the same in posts, so I don't know what's the point of your comment once again.
Reply
#13
Solved: 6 Years, 8 Months, 1 Week ago
But he wants rtl text which you read from right to left, like in Hebrew and Arabic languages. The css rtl property should do that.
Regards, Ad Bakker (NL)
Reply
#14
Solved: 6 Years, 8 Months, 1 Week ago
yes i want urdu text that is from right to left .
Reply
#15
Solved: 6 Years, 8 Months, 1 Week ago
I'm not an expert, but try to change to change span into div in your mycode. All the examples I see are with div's.
Regards, Ad Bakker (NL)
Reply
#16
Solved: 6 Years, 8 Months, 1 Week ago
(2015-02-03, 09:27 PM)dragonexpert Wrote: You can make a custom MyCode For it.
Regex: \[rtl\](.*)\[\/rtl\]
Replacement:<span style="direction:rtl">$1</span>

(2015-02-04, 08:54 PM)Ad Bakker Wrote: I'm not an expert, but try to change to change span into div in your mycode. All the examples I see are with div's.



You can make a custom MyCode For it.
Regex: \[rtl\](.*)\[\/rtl\]
Replacement:<div style="text-align:justify;" dir="rtl">$1</div>


thank you very much both of you  , this code works fine .
Reply
#17
Solved: 6 Years, 8 Months, 1 Week ago
how to fix this bug ?


while in normal mode we format some text and when we post that paragraph it it is generating some extra space , all the time and when we switch to source mode it shows BBCode on each line and we have some extra space (enters) too .

is there any way to fix this ?

note: today i check SCeditor on www.sceditor.com , that demo editor have same bug as it is in mybb Sad 
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)