MyBB GoMobile for 1.8.*
#1
10.10.16: I am no longer going to update this as I lost interests in keeping it updated. I forked the plugin back in 2015 when I used it for my own forum. I am now using a fully responsive bootstrap theme I made by myself. In MyBB 2.0, the default theme will be responsive from what I've heard. You may go ahead and fork the plugin on my GitHub if you want to keep it updated.







MyBB GoMobile (Support for 1.8.*)

In case you don't know what GoMobile is, it's a plugin for MyBB that detects mobile devices and simply switch the theme for that user over to a mobile theme. 

I noticed that the original version of MyBB GoMobile was outdated, I therefore forked it and updated it on my own. It should be fully compatible with any 1.8 update. The theme is just a basic theme, I therefore recommend you to use any other theme that is responsive. My favorite is example this and I am currently using that on my own forum. You may set any theme you want as in the settings in the ACP by using the theme ID.


If you have any questions, bugs or got any other problems, please report them on the GitHub repo.
From what I know, it should work with 1.8 versions. However this comes with no guarantee.



Heres a preview of the basic theme, which is fully customizable.
[Image: OFNp6Bt.png]


You may direct download it here for FREE:

You may also use this in case you want to check out the repository:
Reply
#2
i have installed this plugin but when try to register i got this message :Our systems detect that
you may be a spammer
and therefore you have
been denied registration. If
you feel this is a mistake,
please contact the Administrator.
Reply
#3
Check the member register template.
Random Fish and Sims Maniac
MY PLUGINS
Help MyBBSupport help you - remember to mark your threads as solved


Reply
#4
(02-06-2015, 05:18 AM)iturdu Wrote: i have installed this plugin but when try to register i got this message :Our systems detect that
you may be a spammer
and therefore you have
been denied registration. If
you feel this is a mistake,
please contact the Administrator.


Should be fixed now. I forgot to update member_register template. Re-download  Smile
Reply
#5
i have updated it myself now working .

how i change this text please see screenshots it is too difficult to read .


Attached Files Thumbnail(s)
           
Reply
#6
My problem is I can't switch to full version, I could before, but after I tried editing ungrouped templates>redirect switching no longer works. I had changed the refreshed time to 5s but changed it back to 2s, l tried deactivating and uninstalling, then uploading and overwriting the plugin files and activating again, but still then same, used 3 different browsers on my android phone
Reply
#7
(02-06-2015, 08:43 AM)iturdu Wrote: i have updated it myself now working .

how i change this text please see screenshots it is too difficult to read .
If you are trying to change the color, look into the global.css and search for ".tfoot".

You may find it here: ACP > Templates & Style > Themes > MyBB GoMobile > global.css


(02-10-2015, 08:27 PM)enelly Wrote: My problem is I can't switch to full version, I could before, but after I tried editing ungrouped templates>redirect switching no longer works. I had changed the refreshed time to 5s but changed it back to 2s, l tried deactivating and uninstalling, then uploading and overwriting the plugin files and activating again, but still then same, used 3 different browsers on my android phone


I can't reproduce this on my own forum. But you can try to revert the redirect template to original by clicking on options in Ungrouped Templates, then "Revert to Original".
Reply
#8
I actually deactivated the plugin and deleted all the files in ./inc/plugins then uploaded the files again. Now working, but the css, especially the board message and newthread css, the page shifts to the right, leaving the header & footer at the left, how can i handle it, anywhere, that happens only on opera and opera mini, looks ok on other browsers.
Reply
#9
(02-12-2015, 09:14 PM)enelly Wrote: I actually deactivated the plugin and deleted all the files in ./inc/plugins then uploaded the files again. Now working, but the css, especially  the board message and newthread css, the page  shifts to the right, leaving the header & footer at the left, how can i handle it, anywhere, that happens only on opera and opera mini, looks ok on other browsers.

Ah, I see. The plugin is missing the strings for these browsers. I am looking into it.
Reply
#10
Bookmarked.

This is brilliant stuff - exactly what I've been looking for - I've been running the older version and it gives some issues, so this is potentially a board saver as most of my members use mobiles and hate tapatalk.

Biggest gripe on other version was when you've got a password protected sub forum, that's only available to paid subscribers, the "jump to first unread post" doesn't seem to work - I stripped back the relevant templates, but couldn't for the life of me find what was causing it...

For reference - the Quote post will not work.

It requires a change to the postbit_quote template, so, if already installed, you need to do a mysql update

http://community.mybb.com/thread-152158.html

For ease of keeping it to this thread :

In your PHPMyAdmin, run

UPDATE YOUR DATABASE NAME.mybb_templates SET template = '<a href="newreply.php?tid={$tid}&amp;replyto={$post[''pid'']}" class="button">{$lang->gomobile_post_quote}</a>' WHERE mybb_templates.version ='1601' AND title ='postbit_quote';

1 row should be affected, and then you're good to go.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)