Jump to the post that solved this thread.
Solved: 4 Years, 6 Months, 1 Week ago Deleting a thread not work properly.
#11
Solved: 4 Years, 6 Months, 1 Week ago
re,
with the tutorial from Destroy666

Open editpost.php, find this line: https://github.com/mybb/mybb/blob/featur...t.php#L275 and change it to:
if(false)

Do the same with this for posts: https://github.com/mybb/mybb/blob/featur...t.php#L319
[/quote]

I have this problem:

[Image: 7QxJ.jpg]

[Image: vNpD.jpg]

I have after delete the message box: "The post was deleted successfully".

But now, the background is lila and the thread is not delete permanently.

[Image: AQkq.jpg]

I can restore the thread.

So how can I delete permanently the thread with the click on the button delete?

Thanks in advance for your help!


I tried to express myself as clearly as possible Angel

Greets,
blongso
Reply
#12
Solved: 4 Years, 6 Months, 1 Week ago
There's a setting for this. Go in AdminCP -> Configuration -> Posting and select no for the setting Enable Soft Delete for Users
My Projects - Support My Projects

Don't forget to rate posts!
Reply
#13
Solved: 4 Years, 6 Months, 1 Week ago
(2017-04-02, 07:43 AM)chack1172 Wrote: There's a setting for this. Go in AdminCP -> Configuration -> Posting and select no for the setting Enable Soft Delete for Users

Thank you chack1172,
Enable Soft Delete for Users - No was already activated
Reply
#14
Solved: 4 Years, 6 Months, 1 Week ago
You can try to edit file editpost.php
At line 278, change this:
if($mybb->settings['soft_delete'] == 1 || is_moderator($fid, "cansoftdeletethreads"))
with this:
if($mybb->settings['soft_delete'] == 1 && is_moderator($fid, "cansoftdeletethreads"))
My Projects - Support My Projects

Don't forget to rate posts!
Reply
#15
Solved: 4 Years, 6 Months, 1 Week ago
YES!!!!!!!!!!!!!!!!!!!!!!!!!!! Big Grin Big Grin

Thanks chack1172!!
That was the solution for me!

Thank you very much!

Greets,
blongso
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)