Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 4 Years, 7 Months, 1 Week ago Login Error after new installation of MyBB 1.8.4
#1
Solved: 4 Years, 7 Months, 1 Week ago
hello,

I can't login to my newly installed MyBB 1.8.4. I installed it on my debian vserver and all seems to be okay. But after I had successfully installed myBB and delete install directory, the admin user wont login correctly. MyBB tells me user logged in, but when I returned to index, nothing happend. The admin panel is accessable
but as soon as I click on config MyBB tells me to login again and then my account is invalid -.-

I used google before I create this Thread but I found no solution.

please help.

regards
Reply
#2
Solved: 4 Years, 7 Months, 1 Week ago
(you're in 1.6 section and speaking of 1.8)

Seems to be a trouble with cookies, check them (cookiedomain, cookiepath and cookieprefix) in inc/settings.php and in your database (table mybb_settings)
[MyBB 1.8 mods] - Offer me a coffee
Do not ask me help through PM
Reply
#3
Solved: 4 Years, 7 Months, 1 Week ago
- Moved to 1.8 Installation Support -
Reply
#4
Solved: 4 Years, 7 Months, 1 Week ago
sorry for posting in the wrong section.

here it is:
$settings['cookiedomain'] = ".84.19.*.*:8078";
$settings['cookiepath'] = "/forum/";
$settings['cookieprefix'] = "";
Reply
#5
Solved: 4 Years, 7 Months, 1 Week ago
The port in the cookie domain ? Try without ":8078"
[MyBB 1.8 mods] - Offer me a coffee
Do not ask me help through PM
Reply
#6
Solved: 4 Years, 7 Months, 1 Week ago
I have changed my Apache port to 8078 maybe installation of MyBB set autocatically.
Reply
#7
Solved: 4 Years, 7 Months, 1 Week ago
Ports are irrelevant to cookies. Just put the IP address with a leading period. ".84.19.*.*".
RedHat Certified Systems Administrator
Reply
#8
Solved: 4 Years, 7 Months, 1 Week ago
(03-11-2015, 06:08 PM)spork985 Wrote: Ports are irrelevant to cookies. Just put the IP address with a leading period. ".84.19.*.*".
No, IP addresses are no domain therefor the cookie domain must be empty.
[Image: banner.png]
Reply
#9
Solved: 4 Years, 7 Months, 1 Week ago
Using ip addresses works, and the RFC accept it, cf http://www.ietf.org/rfc/rfc2109.txt
[MyBB 1.8 mods] - Offer me a coffee
Do not ask me help through PM
Reply
#10
Solved: 4 Years, 7 Months, 1 Week ago
(03-11-2015, 06:08 PM)spork985 Wrote: Ports are irrelevant to cookies. Just put the IP address with a leading period. ".84.19.*.*".


thank y0u dude. login work now correctly without ports iin 'cookiedomain' Shy
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)