Thread Rating:
  • 4 Vote(s) - 3.25 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.8] DVZ Secure Content 1.1.5
#11
(07-02-2015, 10:09 AM)Devilshakerz Wrote:
(07-02-2015, 03:11 AM)General Awesome Wrote: This broke the crap out of my forum: https://www.rpgcreation.net/community/sh...357#pid357

I definitely recommend doing a DB backup before trying this plugin.

Any idea about how to fix this mess?

This plugin prevents unsecure user-generated content from displaying only - it does not interfere with the forum style.
Your forum displays correctly on http://; browsers don't load CSS and other files from non-HTTPS sources while the website loading them is sent over HTTPS - to make it work you need to change the Board URL (Site Details) so it begins with https://.

No, you cannot see the problems it caused now. It took me 4 hours to repair the DB from the damage this plugin caused last night. It inserted weird <object> html throughout my templates.
Reply
#12
(07-02-2015, 06:02 PM)General Awesome Wrote: No, you cannot see the problems it caused now. It took me 4 hours to repair the DB from the damage this plugin caused last night. It inserted weird <object> html throughout my templates.

Can you provide the part of the database that was corrupted, the theme containing damaged templates or describe these changes more precisely on PM? I am not able to reproduce the issue.
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply
#13
(07-02-2015, 07:11 PM)Devilshakerz Wrote:
(07-02-2015, 06:02 PM)General Awesome Wrote: No, you cannot see the problems it caused now. It took me 4 hours to repair the DB from the damage this plugin caused last night. It inserted weird <object> html throughout my templates.

Can you provide the part of the database that was corrupted, the theme containing damaged templates or describe these changes more precisely on PM? I am not able to reproduce the issue.

I'll set up a sandbox forum and reproduce the error for you tonight. Smile
Reply
#14
Broke my site on the theme that I bought from you. When I deactivated it and uninstalled it replaced most global templates and other ones with this code:
<object width="410" height="341" id="veohFlashPlayer" name="veohFlashPlayer"><param name="movie" value="http://www.veoh.com/swf/webplayer/WebPlayer.swf?version=AFrontend.5.7.0.1446&amp;permalinkId=&amp;player=videodetailsembedded&amp;videoAutoPlay=0&amp;id=anonymous"><param name="allowFullScreen" value="true"><param name="allowscriptaccess" value="always"><embed src="http://www.veoh.com/swf/webplayer/WebPlayer.swf?version=AFrontend.5.7.0.1446&amp;permalinkId=&amp;player=videodetailsembedded&amp;videoAutoPlay=0&amp;id=anonymous" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="410" height="341" id="veohFlashPlayerEmbed" name="veohFlashPlayerEmbed"></object>
Reply
#15
Version 1.0.2 (build #5, MD5: e32962ad6c81773e92d8f04f18650d5f)
  • fixed avatar overwriting when using Gravatar
  • minor code corrections

Upgrading: Overwrite inc/plugins/dvz_secure_content.php.

http://community.mybb.com/mods.php?actio...0&bid=1433
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply
#16
this is another layer of a parser?
Reply
#17
Somewhat yes - the plugin converts images back to links; it could be more optimal if more plugin hooks were present in the parser code.
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply
#18
On pages where I have gravatar images the green lock does not appear. Photobucket and postimage.org images are replaced with links so that the green lock appears. What's supposed to happen with the gravatars ?

Nevermind, found it (the setting) ! Thanks, nice plugin.
What goes around comes around
Reply
#19
This user has been denied support. This user has been denied support.
(04-11-2015, 11:39 PM)p00lz Wrote: Parse error: syntax error, unexpected '[' .../inc/plugins/dvz_secure_content.php on line 5

thats weird, when i go on plugin page...

i have this error
Reply
#20
Also, any plans to update this for latest MyBB 1.8.7 ??

And will this work properly on 1.8.7 ?

Thanks
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)