Solved: 6 Years, 1 Month, 3 Weeks ago [Error Message] Inline Moderation Error
#1
Solved: 6 Years, 1 Month, 3 Weeks ago
Hello.

I am using MyBB version 1.8.3. When I am selecting one or more threads to perform actions on them, I get this:

Sorry, but you did not select any threads to perform inline moderation on, or your previous moderation session has expired (Automatically after 1 hour of inactivity). Please select some threads and try again.


I heard that there's a problem with jQuery but I don't really get it. Please help me out.




headerinclude code:
<link rel="alternate" type="application/rss+xml" title="{$lang->latest_threads} (RSS 2.0)" href="{$mybb->settings['bburl']}/syndication.php" />
<link rel="alternate" type="application/atom+xml" title="{$lang->latest_threads} (Atom 1.0)" href="{$mybb->settings['bburl']}/syndication.php?type=atom1.0" />
<meta http-equiv="Content-Type" content="text/html; charset={$charset}" />
<meta http-equiv="Content-Script-Type" content="text/javascript" />
<script type="text/javascript">jQuery.noConflict();</script> 



<!--JQuery-->

<script type='text/javascript' src='/master/jquery/jquery.js'></script>


<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/twist-sd/jquery.js"></script>

   <script type="text/javascript">

     jQuery.noConflict();
  
 </script>


<!--JQuery-->


<!--Modal box-->

<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/twist-sd/modalbox/jquery.simplemodal.js"></script>

<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/twist-sd/modalbox/basic.js"></script>

<!--Modal box-->

<!--Tiptip-->

<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/twist-sd/tiptip/jquery.tipTip.js"></script>

<script type="text/javascript">
 jQuery(function(){
 jQuery(".tooltip").tipTip();
 });
 </script> 

<link rel="stylesheet" type="text/css" href="{$mybb->settings['bburl']}/jscripts/twist-sd/tiptip/tiptip.css" />

<!--Tiptip-->


<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/prototype.js?ver=1603"></script>

<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/general.js?ver=1603"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/popup_menu.js?ver=1600"></script>

{$stylesheets}





<script type="text/javascript">
<!--
 var cookieDomain = "{$mybb->settings['cookiedomain']}";
 var cookiePath = "{$mybb->settings['cookiepath']}";
 var cookiePrefix = "{$mybb->settings['cookieprefix']}";
 var deleteevent_confirm = "{$lang->deleteevent_confirm}";
 var removeattach_confirm = "{$lang->removeattach_confirm}";
 var loading_text = '{$lang->ajax_loading}';
 var saving_changes = '{$lang->saving_changes}';
 var use_xmlhttprequest = "{$mybb->settings['use_xmlhttprequest']}";
 var my_post_key = "{$mybb->post_code}";
 var imagepath = "{$theme['imgdir']}";
// -->
</script>
{$newpmmsg}
Reply
#2
Solved: 6 Years, 1 Month, 3 Weeks ago
first of all what theme are you using... is it made for 1.8... the headerinclude has prototype.js which is no longer used in 1.8... if you are using a old theme made for 1.6, better switch to a 1.8 compatible theme....


coming to your query, you are loading the jquery and the noconflict codes twice... remove both instances of the no conflict script....


<script type="text/javascript">jQuery.noConflict();</script> 


<script type="text/javascript">

    jQuery.noConflict();
 
</script>


and remove one of the jquery...

<script type='text/javascript' src='/master/jquery/jquery.js'></script>


<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/twist-sd/jquery.js"></script>
We can't help everyone, but everyone can help someone - Ronald Reagan
Did you know? Your question has already been answered. But you haven't searched it yet.
Don’t  Forget to “Mark as Solved” after the fix
Reply
#3
Solved: 6 Years, 1 Month, 3 Weeks ago
(2015-03-24, 06:07 AM)mmadhankumar Wrote: first of all what theme are you using... is it made for 1.8... the headerinclude has prototype.js which is no longer used in 1.8... if you are using a old theme made for 1.6, better switch to a 1.8 compatible theme....


coming to your query, you are loading the jquery and the noconflict codes twice... remove both instances of the no conflict script....


<script type="text/javascript">jQuery.noConflict();</script> 


<script type="text/javascript">

    jQuery.noConflict();
 
</script>


and remove one of the jquery...

<script type='text/javascript' src='/master/jquery/jquery.js'></script>


<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/twist-sd/jquery.js"></script>

Thank you very much. I've copied the headerinclude code from the default theme and pasted it into my own theme, works good now, thanks!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)