Not Solved [mysql error] 1364 - Field 'ougc_awards' doesn't have a default value
#1
Not Solved Exclamation 
Hey Mybb Community!

I was going through some testing in my forum and i found out while trying to register it gave me a mysql error:
MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1364 - Field 'ougc_awards' doesn't have a default value
Query:
INSERT INTO mybb_users (`username`,`password`,`salt`,`loginkey`,`email`,`postnum`,`threadnum`,`avatar`,`avatartype`,`usergroup`,`additionalgroups`,`displaygroup`,`usertitle`,`regdate`,`lastactive`,`lastvisit`,`website`,`icq`,`aim`,`yahoo`,`skype`,`google`,`birthday`,`signature`,`allownotices`,`hideemail`,`subscriptionmethod`,`receivepms`,`receivefrombuddy`,`pmnotice`,`pmnotify`,`showimages`,`showvideos`,`showsigs`,`showavatars`,`showquickreply`,`showredirect`,`tpp`,`ppp`,`invisible`,`style`,`timezone`,`dstcorrection`,`threadmode`,`daysprune`,`dateformat`,`timeformat`,`regip`,`language`,`showcodebuttons`,`sourceeditor`,`away`,`awaydate`,`returndate`,`awayreason`,`notepad`,`referrer`,`referrals`,`buddylist`,`ignorelist`,`pmfolders`,`warningpoints`,`moderateposts`,`moderationtime`,`suspendposting`,`suspensiontime`,`coppauser`,`classicpostbit`,`usernotes`) VALUES ('tester8986','9ec34d5c40e7939312215318937cbff3','AnpyKBKE','IgDz7RS91TEkjKigmbTEkF1XmNrIreFQvJIVkcuRiquDfYkjgv','[email protected]','0','0','','','5','','0','','1427583840','1427583840','1427583840','','0','','','','','','','1','0','0','1','0','1','0','1','1','1','1','1','1','0','0','0','0','0','2','linear','0','','',X'c0a80101','','1','1','0','0','0','','','0','0','','','','0','0','0','0','0','0','0','')
The Plugins I Have Installed Are:
-OUGC Awards
-OUGC Additional Usergroup Images

My Site Is: http://tug.weathercraftnetwork.net/forum/

Thanks In Advance!
~Weather
Reply
#2
Not Solved
http://community.mybb.com/thread-116640-page-18.html

You'll more likely get the dev's attention by posting in the official release thread.
Reply
#3
Not Solved
@Mikeh
Thanks! Notified the developer. ill post a fix here incase anyone needs it
Reply
#4
Not Solved
Well so far no fix as i know of....
If there's any fix is that to uninstall the plugin and wait.
Reply
#5
Not Solved
^ plugin coder will fix it when he gets required time for it. you can subscribe to the issue on GitHub

Edit: deactivate & uninstall the plugin and comment out line 466 in the plugin file (ougc_awards.php)
	!$db->field_exists('users', 'ougc_awards') or $db->drop_column('ougc_awards', 'users');


that should temporarily fix the referred issue. And you can wait for the plugin coder's fix
Reply
#6
Not Solved
Hmm nope did not work
Reply
#7
Not Solved
Hate to grave dig but since i had the same problem (new user can't register with this plugin installed) and i found this post
and it seems like the bug is fixed in the newest version found here https://github.com/Sama34/OUGC-Awards

the one that is currently on site is broken
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)