Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MyBB 1.8.4 with Google SEO mod :( The page you are looking for cannot be found
#1
Ok... This is taking way too long now Sad I hired a coder to solve this, but he too gave up :/

My forum: MyBB 1.8.4, http://crypto.country/forum

I tried a lot of things... A lot. And I don't know what the coder guy did, but he went at it too :/

I have .htaccess in /public_html (not /public_html/forum). It's copy pasted from the plugin, before applying. See code below

Google SEO (1.6.8)
Google Search Engine Optimization as described in the official Google's SEO starter guide. Please see the documentation for details.
Add to .htaccess:
RewriteEngine on

# Some hosts require RewriteBase to make RewriteRules work.
RewriteBase /forum/

# Google SEO workaround for search.php highlights:
# Make this rule the first rewrite rule in your .htaccess!
RewriteRule ^([^&]*)&(.*)$ http://crypto.country/forum/$1?$2 [L,QSA,R=301]

# Google SEO 404:
ErrorDocument 404 /forum/misc.php?google_seo_error=404

# Google SEO Sitemap:
RewriteRule ^sitemap\-([^./]+)\.xml$ misc.php?google_seo_sitemap=$1 [L,QSA,NC]

# Google SEO URL Forums:
RewriteRule ^Forum\-([^./]+)$ forumdisplay.php?google_seo_forum=$1 [L,QSA,NC]

# Google SEO URL Threads:
RewriteRule ^Thread\-([^./]+)$ showthread.php?google_seo_thread=$1 [L,QSA,NC]

# Google SEO URL Announcements:
RewriteRule ^Announcement\-([^./]+)$ announcements.php?google_seo_announcement=$1 [L,QSA,NC]

# Google SEO URL Users:
RewriteRule ^User\-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

# Google SEO URL Calendars:
RewriteRule ^Calendar\-([^./]+)$ calendar.php?google_seo_calendar=$1 [L,QSA,NC]

# Google SEO URL Events:
RewriteRule ^Event\-([^./]+)$ calendar.php?action=event&google_seo_event=$1 [L,QSA,NC]

404, Meta, Redirect, Sitemap and URL are enabled. (Configure)
Click to Revert changes to core files.

When disabled, I have this as status: URL is passive. Apply changes to core files to activate.
Redirect is enabled and URL is passive. Redirecting SEO URLs back to MyBB's default URLs. (which seems to be correct).

I tried all combinations here too:
Server and Optimization Options

Enable search engine friendly URLs?
Search engine friendly URLs change the MyBB links to shorter URLs which search engines prefer and are easier to type. showthread.php?tid=1 becomes thread-1.html. Once this setting is enabled you need to make sure you have the MyBB .htaccess in your MyBB root directory (or the equivalent for your web server). Automatic detection may not work on all servers. Please see the MyBB Docs for assistance.
(Automatic/Enabled/Disabled)

Enable search engine friendly URLs in Archive?
Search engine friendly URLs can be used in the archive. Once this setting is enabled ensure the archive still works as expected.
(Yes/No)

All the URLs are adjusted. Eg. if I set URLs to search engine thread-1.html style, when I hoover a link it indeed shows that as the target URL. But FOLLOWING that link gives Google's 404 page... Same for true SEO optimized naming scheme... url with "my_subject_title" is shown, it just 404s. Sigh!

Also a note for people struggling with this: it seems to take a while before all settings are reflected. So you must not only refresh the cache for the forum page, but then wait a little too... Brought me a lot of panic feels already :/

So what else should I look for? The SEO installation, though complicated, seems to be a well known process, easy'ish enough to install on MyBB 1.8.4, even for me. Right?

Any insights / tips / pointers GREATLY appreciated!

Devvie
twitter.com/devnullius

(PS: I removed all references for www, because I had a warning about that before. More details? http://community.mybb.com/thread-170074-...pid1155233)

----
Strange! I just pressed the link in an old email where I have this link:
http://www.crypto.country/forum/showthre...?tid=23721

it now redirects too:
http://crypto.country/forum/showthread.p...rect=debug

The page loads, so that's good. But I can't explain the seo-redirect addition to the URL :s Straaaange! : )
#2
1. Activate the SEO Plugin

2. Click on "Apply Changes to core files" link in the ACP >> Plugins >> Google SEO

3. Rename the htaccess.txt found in your root folder (in your case public_html/forum) into .htaccess (there should be . (dot) in front of the file name)

4. Copy those rewrite rules shown Under Google SEO on the Plugins page and put in the .htaccess file
those rules go as the first set of rules in that file...
We can't help everyone, but everyone can help someone - Ronald Reagan
Did you know? Your question has already been answered. But you haven't seen it yet.
Don’t  Forget to “Mark as Solved” after the fix
#3
(04-27-2015, 06:55 AM)mmadhankumar Wrote: 1. Activate the SEO Plugin
2. Click on "Apply Changes to core files" link in the ACP >> Plugins >> Google SEO
3. Rename the htaccess.txt found in your root folder (in your case public_html/forum) into .htaccess (there should be . (dot) in front of the file name)
4. Copy those rewrite rules shown Under Google SEO on the Plugins page and put in the .htaccess file

Yeah, like I said, we've done all that... Not working!

My programmer wrote down "his" stuff here:
http://community.mybb.com/thread-170089.html
#4
this thread is closed.
further communication related to this issue can be done at the other thread


Forum Jump:


Users browsing this thread: 1 Guest(s)