Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 4 Years, 4 Months, 1 Week ago RSS (syndication.php) doesn't support SSL
#1
Solved: 4 Years, 4 Months, 1 Week ago
Detailed description of your problem: RSS feeds are for some reason not using SSL which causes third party social media managers like hootsuite and twitterfeed to fail.
URL to your forum: https://tubecenter.net
URL to specific problematic page: https://tubecenter.net/syndication.php?limit=15
New installation or upgrade: Fresh install at 1.8.0 (currently 1.8.4)
Test user account: not required
Reply
#2
Solved: 4 Years, 4 Months, 1 Week ago
It appears to work for me. In Chrome, Safari, and Firefox, I'm able to access the syndication over HTTPS, and add the feeds to an RSS aggregator of mine.

Could you clarify your steps to reproduce? Is it only an issue with HootSuite?
PGP Key (Fingerprint: 23B6 F4C0 FE2D 45AA 61A0 1E86 DB87 09DC DD87 6E40)
Reply
#3
Solved: 4 Years, 4 Months, 1 Week ago
(05-05-2015, 02:09 AM)Josh H. Wrote: It appears to work for me. In Chrome, Safari, and Firefox, I'm able to access the syndication over HTTPS, and add the feeds to an RSS aggregator of mine.

Could you clarify your steps to reproduce? Is it only an issue with HootSuite?

While the URL is https it seems that the connection isn't encrypted. This is seen most clearly in Firefox:

[Image: 2q1xxk0.jpg]

W3C feed validation service also indicates that there is a problem: https://validator.w3.org/feed/check.cgi?...limit%3D15

Hootsuite, twitterfeed, Buffer (pretty much all of these) tell me the feed URL is invalid.
Reply
#4
Solved: 4 Years, 4 Months, 1 Week ago
This has nothing to do with MyBB. It seams these services can't establish a connection to your server at all due to problems with TLS (likely relying on ciphers Cloudflare has disabled or using SSLv3).
[Image: banner.png]
Reply
#5
Solved: 4 Years, 4 Months, 1 Week ago
I have just contacted CloudFlare support and linked them to this thread. I will be waiting for a response.

As far as I know, CloudFlare has disabled SSLv3 on their entire network. Also, the RSS feeds are the only thing that doesn't seem to work.

Here's another idea: Is it possible to move syndication.php to another directory/subdomain? This would allow me to just disable TLS altogether for this specific URL which should be a quick and dirty solution to the problem.
Reply
#6
Solved: 4 Years, 4 Months, 1 Week ago
I've figured out how to move the syndication.php

You can place it pretty much anywhere on the server as long as you change the php-includes to point to the board directory.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)