Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved Warning [2] require() [function.require]: open_basedir restriction in effect.
#11
Not Solved
Hi,

There really isn't any other solution if your web host cannot change the open_basedir restriction. They obviously changed it before if this issue only started happening recently and it worked in the past.
#12
Not Solved
are you using multiple domains on single hosting account - looks like host wants to discourage using multiple domains ..
#13
Not Solved
(05-20-2015, 09:01 AM)Euan T Wrote: There really isn't any other solution if your web host cannot change the open_basedir restriction.
Could you please tell me more specific what they should do and I'll ask them to do exactly that.


(05-20-2015, 09:02 AM).m. Wrote: are you using multiple domains on single hosting account - looks like host wants to discourage using multiple domains ..
Well, i have 3 domains (separated websites) in my hosting account.
#14
Not Solved
You'll have to ask them to add the path to your forum root to the open_basedir. In your case, you'll have to get "/home/my_directory/domains/my_directory/public_html/my_directory/" added.

This also may be possible using .htaccess: http://stackoverflow.com/a/223834
#15
Not Solved
I just have asked my hosting suport to add forum root to the open_basedir, they did, very quickly in fact, please see here the open_basedir variable:
http://om.md/board/phpinfo.php

Yet, it did not help. I still get same errors. Any other idea?

Thanks.
#16
Not Solved
Hi,

I do not see the error on your forum now?
#17
Not Solved
Well, i downgraded mybb only directory to PHP v5.2 using .htaccess.


Forum Jump:


Users browsing this thread: 1 Guest(s)