Jump to the post that solved this thread.
Solved: 7 Years, 3 Months, 3 Weeks ago Changing domain name
#1
Solved: 7 Years, 3 Months, 3 Weeks ago
My current domain: http://spamheaven.co - I purchased http://spamheaven.com and I want my board to be on the .com domain. How to do that?
Reply
#2
Solved: 7 Years, 3 Months, 3 Weeks ago
1. Change the Board url & Cookie settings in inc/settings.php file...

2. and then change them at ACP >> Configuration >> Site Details as well...
We can't help everyone, but everyone can help someone - Ronald Reagan
Did you know? Your question has already been answered. But you haven't searched it yet.
Don’t  Forget to “Mark as Solved” after the fix
Reply
#3
Solved: 7 Years, 3 Months, 3 Weeks ago
I don't see where to change stuff in inc/settings.php. Here is da file:

<- snip ->
$settings['bbname'] = "Spam Heaven";
$settings['bburl'] = "http://spamheaven.com";

<- snip -> 

$settings['cookiedomain'] = ".spamheaven.com";
$settings['cookiepath'] = "/";
$settings['cookieprefix'] = "";

<- snip ->
Reply
#4
Solved: 7 Years, 3 Months, 3 Weeks ago
^ you already have correct settings for .com domain in the settings.php file
Reply
#5
Solved: 7 Years, 3 Months, 3 Weeks ago
Oh. Because I changed in settings in ACP? But... when going to my forum, it says 403 Forbidden, can't access / on this server, etc.

Nevermind. I fixed it. In fact, I already knew to edit settings and inc/settings.php by reading other threads about this on this forum. But my real mistake was in my web-host: For where spamheaven.com got it's files: I pointed it to public_html/spamheaven.com - but that directory doesn't have anything in it. It should be public_html, and I have fixed it. Thank you, guys.
Reply
#6
Solved: 7 Years, 3 Months, 3 Weeks ago
^ yes, changes done in admin panel are stored in the database & reflected through settings.php file.

for the 403 Forbidden error
you have to check file permissions, rewrite rules in .htaccess & trace server error log if it is available at web host control panel
Reply
#7
Solved: 7 Years, 3 Months, 3 Weeks ago
Oh, and the 403 error was because public_html/spamheaven.com wasn't CHMODDED correctly.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)