Thread Rating:
  • 13 Vote(s) - 4.54 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MyAlerts v2.0.4
You're using the number of unread PMs for both alerts and PMs. Change the code to:

<span class="alerts {$newAlertsIndicator} sep"><a href="{$mybb->settings['bburl']}/alerts.php" title="alerts" class="myalerts open_modal"
      data-selector="#myalerts_alerts_modal" rel="modal:open"><i style="color: #fff; font-size: 17px;" class="fa fa-bell-o  fa"></i> <span class="pms">{$mybb->user['unreadAlerts']} </span></a></span>    
    
<span class="sep"><a href="{$mybb->settings['bburl']}/private.php" title="Private messages"><i style="color: #fff; font-size: 17px;" class="fa fa-envelope fa"></i> <span class="pms">{$mybb->user['pms_unread']} </span></a></span>
Reply
(2017-03-18, 09:42 AM)Euan T Wrote: You're using the number of unread PMs for both alerts and PMs. Change the code to:

<span class="alerts {$newAlertsIndicator} sep"><a href="{$mybb->settings['bburl']}/alerts.php" title="alerts" class="myalerts open_modal"
      data-selector="#myalerts_alerts_modal" rel="modal:open"><i style="color: #fff; font-size: 17px;" class="fa fa-bell-o  fa"></i> <span class="pms">{$mybb->user['unreadAlerts']} </span></a></span>    
    
<span class="sep"><a href="{$mybb->settings['bburl']}/private.php" title="Private messages"><i style="color: #fff; font-size: 17px;" class="fa fa-envelope fa"></i> <span class="pms">{$mybb->user['pms_unread']} </span></a></span>


Hi Euan,

Thanks for your fast reply. But when I change the code to your it's the same.

What I want is:

When i "tag/shoutout" @testuser in my thread I want that "testuser" should get an alert. 
Now, when i tag @testuser I can't see the (0) be a (1). But when I messages testuser he get a (1) on both of them.

I hope you understand.
Reply
Hi,

Any chance you can PM me your URL and details for a temporary admin account so I can look at it?
Reply
(2017-03-18, 02:01 PM)Euan T Wrote: Hi,

Any chance you can PM me your URL and details for a temporary admin account so I can look at it?

I've done that now Smile
Reply
Photo 
(2017-03-18, 09:42 AM)Euan T Wrote: You're using the number of unread PMs for both alerts and PMs. Change the code to:

<span class="alerts {$newAlertsIndicator} sep"><a href="{$mybb->settings['bburl']}/alerts.php" title="alerts" class="myalerts open_modal"
      data-selector="#myalerts_alerts_modal" rel="modal:open"><i style="color: #fff; font-size: 17px;" class="fa fa-bell-o  fa"></i> <span class="pms">{$mybb->user['unreadAlerts']} </span></a></span>    
    
<span class="sep"><a href="{$mybb->settings['bburl']}/private.php" title="Private messages"><i style="color: #fff; font-size: 17px;" class="fa fa-envelope fa"></i> <span class="pms">{$mybb->user['pms_unread']} </span></a></span>

[Image: 687474703a2f2f692e696d6775722e636f6d2f6e...482e706e67]

Hi Euan,

you know what would be cool,
is there a way to make the red icon blocks that hold the alert count number, to only appear (pop up) only when there is a only a new alert? that would be seriously awesome...
so it would pop up and say "1"

as an example.
Hey man, what's up?
Reply
that can be done via css i have that feature since mybb 1.8.0 for mps and i add it into myalerts but every style is diferent between default one.

But if i have sane theme i can guide you to get that customization.
The only infinite thing is the universe and human stupidity, but the universe is not for sure

Plugins 1.6.x

Plugins 1.8.x

Reply
(2017-03-18, 05:01 PM)Dark Neo Wrote: that can be done via css i have that feature since mybb 1.8.0 for mps and i add it into myalerts but every style is diferent between default one.

But if i have sane theme i can guide you to get that customization.

Hey Neo! you are the best man! I really appreciate what you bring to the table! I so appreciate your help!
Hey man, what's up?
Reply
(2017-03-18, 05:01 PM)Dark Neo Wrote: that can be done via css i have that feature since mybb 1.8.0 for mps and i add it into myalerts but every style is diferent between default one.

But if i have sane theme i can guide you to get that customization.

Are you able to help me with that aswell? Did you see my earlier posts?
Reply
Hi Euan,

I'm having an issue similar to that of thelovelyone from December. The MyAlerts settings links aren't displaying correctly on the User CP nav menu. I've checked already that alerts.cp has access to the usercp.css by following the instructions provided by Dark Neo, however that hasn't fixed my problem. I am using the Vienna theme, and the menu looks perfectly fine when using default.

Here is a picture of what it looks like:

[Image: LI0cDg4.png]
Reply
Hi,

The problem is that your theme uses a customised version of usercp.css with different image sizes or paddings or margins. I don't know what theme it is, so I can't say how to fix it. If you can provide me with a URL and details for a temporary admin account I might be able to fix it though.
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)