Thread Rating:
  • 13 Vote(s) - 4.54 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MyAlerts v2.0.4
Hi there,

I would like to ask you for help. I'm trying to run this plugin but I'm facing issues.
First was SQL issue using provided file to create 2 tables. I'm using SQLite3. This issue is now solved, but I'm facing another one (also in attached screenshot):

SQLSTATE[HY000]: General error: 1 table mybb_users has no column named myalerts_disabled_alert_types
Is there any other SQL file/command/query to solve this issue ?
Thank you very much.
Regards,
Zonze

EDIT: issue appeared after trying to register new user
Reply
old my alearts wrecked me
Reply
For some reason the number that shows how many unread alerts you have is missing on my board, any idea why?
Reply
(2019-02-11, 09:54 PM)NotAdmin Wrote: Euan T

I have a bug for you!  - originally I thought it was due to MentionMe, but I'm now certain it is your plugin - originally reported in the MentionMe Thread


Quote:I haven't tested yet, but I think a member has alerted me to a bug; I think it is due to a bug with MentionMe, but it is actually connected to the alerts (MyAlerts)

A member got a barrage of alerts to say he had been tagged; when he followed the link to the post, there was no post and no tag. He contacted the member, who noted that he had created a draft post (where the other member was tagged), and made a number of saves; he thinks that every time he saved the draft the member is getting an alert

Is this a known bug?

As it was a tag causing the phantom alerts, I thought the issue was with the MentionMe plugin, however today a member that was subscribed to a thread received multiple "XYZ has replied to your subscribed thread" alerts, again it was due to another member saving a number of drafts

So it seems that drafts are causing an alert to trigger, and as it triggers every time a save is made, it can be pretty annoying for other members!

Any further info required, just let me know Smile
The MentionMe issue is an issue in MentionMe, but the subscribed threads one is definitely a bug in MyAlerts.

The way that myAlerts is implemented, any plugins integrating with it have to handle all the logic for checking for drafts and handling deleted posts and such - same with core MyAlerts alert types.
(2019-02-13, 08:09 PM)zonze Wrote: Hi there,

I would like to ask you for help. I'm trying to run this plugin but I'm facing issues.
First was SQL issue using provided file to create 2 tables. I'm using SQLite3. This issue is now solved, but I'm facing another one (also in attached screenshot):

SQLSTATE[HY000]: General error: 1 table mybb_users has no column named myalerts_disabled_alert_types
Is there any other SQL file/command/query to solve this issue ?
Thank you very much.
Regards,
Zonze

EDIT: issue appeared after trying to register new user
It looks like the install procedure didn't manage to add all the necessary columns. You should be able to fix it by running this query in phpMyAdmin:
ALTER TABLE mybb_users ADD myalerts_disabled_alert_types TEXT;

(2019-02-14, 01:06 AM)ExclusiveSprx Wrote: old my alearts wrecked me
What do you mean? If you have a problem with myAlerts, a little more information would be useful so that I can try and help.
(2019-02-17, 12:38 AM)deserts Wrote: For some reason the number that shows how many unread alerts you have is missing on my board, any idea why?

Could you please post the content of your "myalerts_headericon" template? If it doesn't contain {$mybb->user['unreadAlerts']}, then the number of unread alerts won't be displayed.
Reply
if anyone want to know, for facebook style alerts, use this

replace myalerts_headericon with

<span class="alerts {$newAlertsIndicator} sep"> 
    <a href="{$mybb->settings['bburl']}/alerts.php" class="myalerts" onclick="MyBB.popupWindow('/alerts.php?modal=1&amp;ret_link={$myalerts_return_link}', { fadeDuration: 250, zIndex: (typeof modal_zindex !== 'undefined' ? modal_zindex : 9999) }); return false;"><i class="fa fa-bell-o" aria-hidden="true"></i><span class="lms dnt{$mybb->user['unreadAlerts']}">{$mybb->user['unreadAlerts']}</span></a></span>


the css


.lms {
    color: #FFF;
    position: relative;
    top: -6px;
    left: -1px;
    padding: 1px 6px 1px 6px;
    text-align: center !important;
    background: #823535;
    -moz-border-radius: 50%;
    -webkit-border-radius: 50%;
    border-radius: 50%;
    text-shadow: 1px 1px 0px #882929;
    box-shadow: 0px 0px 0px 1px rgba(0,0,0,0.25) inset, 0px 1px 4px rgba(0,0,0,0.15);
    font-size: 12px;
}

.dnt0 {
    display: none !important;
}

Hey man, what's up?
Reply
Image preview?

Euan - so no update until v1.9 release? Need auto read alert when I visit the thrrad/post
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
(2019-02-22, 04:50 PM)Eldenroot Wrote: Image preview?

Euan - so no update until v1.9 release? Need auto read alert when I visit the thrrad/post


The preview Shows with alerts and Shows without alert
[Image: GIRP3Tl.png]
Hey man, what's up?
Reply
(2019-02-22, 04:50 PM)Eldenroot Wrote: Image preview?

Euan - so no update until v1.9 release? Need auto read alert when I visit the thrrad/post

It depends whether I get any free time or not. Right now, I have almost 0 free time. I started a rewrite last year to clean a lot of issues up, but didn't get very far before I got too busy again.
Reply
(2019-02-23, 01:48 PM)Euan T Wrote:
(2019-02-22, 04:50 PM)Eldenroot Wrote: Image preview?

Euan - so no update until v1.9 release? Need auto read alert when I visit the thrrad/post

It depends whether I get any free time or not. Right now, I have almost 0 free time. I started a rewrite last year to clean a lot of issues up, but didn't get very far before I got too busy again.

Great plugin
Hey man, what's up?
Reply
I've been having this problem. I'm using MyAlerts with MentionMe. The @ mentions work (ie the dropdown and text highlighting), and the alerts # increases, but when I try to view my alerts or access alert settings via UCP, I get a blank page. 


I tried Serpius' solution here but nothing changed. I've logged in as a regular user, and no dice there either. I am using Mybb 1820 MentionMe 3.2.9 and MyAlerts 2.0.4, and even updated Plugin Library, all the latest versions afaik. 

Zip zero nada. 

Ideas? 

Many thanks!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)