Thread Rating:
  • 13 Vote(s) - 4.54 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MyAlerts v2.0.4
I have an issue where alerts aren't being given for certain events. A user told me they weren't getting alerts for mentions (from the MentionMe plugin) but I also notice alerts don't seem to be given for a reply to a comment either which might rule out a MentionMe issue. Alerts for private messages do work though.

I've gone through rebuilt whatever caches look likely, checked DB etc. Wondering if there are any "quick fixes" to try before starting to debug in a bit more depth? Anyone seen this?

MyAlerts 2.0.4, MentionMe 3.2.12, MyBB 1.8.24. I have PluginLibrary (13) installed but not activated.
Reply
(2021-02-03, 09:01 AM)Rufus McDufus Wrote: I have an issue where alerts aren't being given for certain events. A user told me they weren't getting alerts for mentions (from the MentionMe plugin) but I also notice alerts don't seem to be given for a reply to a comment either which might rule out a MentionMe issue.  Alerts for private messages do work though.

I've gone through rebuilt whatever caches look likely, checked DB etc. Wondering if there are any "quick fixes" to try before starting to debug in a bit more depth? Anyone seen this?

MyAlerts 2.0.4, MentionMe 3.2.12, MyBB 1.8.24.  I have PluginLibrary (13) installed but not activated.

Don't use MentionMe, but have seen this with Tapatalk.  Their use of a separate user table causes no end of undesirable issues.  Tapatalk is a bad / risky plugin on many layers, but understand why many need it.

Just a quick observation.  You don't activate PluginLibrary13, although that's misleading in the ACP plugin section.  Just having it inactive is fine - as mentioned in the install notes.

cheers...
Reply
Thanks. Actually I do have the accursed Tapatalk installed too (and Google SEO is the only other plugin).  I'll try and deactivate it and see.  Nothing has really changed on the site for quite a few months so I'm at a bit of a loss, unless alerts haven't been working for some time.

...just tried deactivating tapatalk, no luck. I'll enable some PHP logging and see if any errors are being thrown.
Reply
Seems you're well on the way to debugging. 

I'll only mention deactivating Tapatalk will leave the database edits - and separate user table in place - mybb_tapatalk_users.  Only a full uninstall will remove that stuff IIRC.  Backup your settings beforehand if you uninstall using the "Delete all data and tables" option in the plugin settings.

Of course if you're having inconsistent results with regular users, this isn't the core issue don't think.  I find regular users work as expected - just Tapatalk users seem to break the rules.

Good luck, and keep us updated...
Reply
Well I had a look and can't really glean anything. First off I think I was being a bit stupid with my testing and simply replying to a comment (and expecting an alert) instead of quoting a comment.  Quoting seems to throw an alert just fine, which suggests the problem may be with just the MentionMe plugin.

However for some weird reason, with a new thread, MentionMe mentions also throw an alert. So... Possibly I've inadvertantly fixed it somewhere along the line but only for new threads.  Well it doesn't look like a MyAlert issue anyway.

[edit] - I just deactivated/uninstalled and then resinstalled MentionMe (and rebuilt its cache) and all seems to work on existing threads as well. So problem gone!
Reply
(2015-05-31, 08:11 PM)Euan T Wrote: General

MyAlerts is a plugin for MyBB. It is a system that provides visual alerts for events in a forum on a user-by-user basis.

MyAlerts requires PluginLibrary to function.

Events

The currently supported events are:
  • When you're quoted in a post
  • When somebody replies to a thread you started
  • When somebody adds you to their buddy list
  • When somebody PMs you
  • When somebody replies to a thread you are subscribed to
More events are currently in development or planned to be added in the near future.

Extensibility

MyAlerts is extensible. This means that any external MyBB plugin can create alerts and add them to a user's feed. Compatible plugins can be found on the wiki, here

GitHub Project

https://github.com/MyBBStuff/MyAlerts

Download and Install

Download the zip from here: https://github.com/MyBBStuff/MyAlerts/ar...master.zip

Upload "alerts.php" to the root of your forum (next to index.php, forum display.php, etc)
Upload everything in "inc" to the "inc" folder, the contents of "images" to "images", etc.

Upload this file to "inc/plugins/MybbStuff/Core/ClassLoader.php": https://raw.githubusercontent.com/MyBBSt...Loader.php

Upload PluginLibrary as described here: https://github.com/frostschutz/MyBB-PluginLibrary

No idea why did it stopped working. 
But it fails to open alerts popup window on custom and default theme.

Checked console. 
There is some jquery issue on custom theme, but no issues on mydefault. Any ideas? 



all sorted
I'm not bothered to have popup so changed

<a href="{$mybb->settings['bburl']}/alerts.php" class="myalerts" onclick="MyBB.popupWindow('/alerts.php?modal=1&amp;ret_link={$myalerts_return_link}', { fadeDuration: 250, zIndex: (typeof modal_zindex !== 'undefined' ? modal_zindex : 9999) }); return false;">{$lang->myalerts_alerts}
({$mybb->user['unreadAlerts']})</a>

to

<a href="{$mybb->settings['bburl']}/alerts.php" class="myalerts" >{$lang->myalerts_alerts}
({$mybb->user['unreadAlerts']})</a>
My forum powered by MyBB https://alhimika.net/forum/
Reply
Hello,
First of all, thank you for your wonderful plugin. We've been using it for a long time now, but haven't made any updates in the past few years. We have now made up for this and encountered a small problem. We now get the following message:



Quote:Fatal error: Uncaught Error: Class 'MybbStuff\SimpleLikes\MybbStuff_MyAlerts_Formatter_AbstractFormatter' not found in /www/htdocs/w01816eb/storming-gates.de/inc/plugins/MybbStuff/SimpleLikes/src/LikeFormatter.php:6 Stack trace: #0 /www/htdocs/w01816eb/storming-gates.de/inc/plugins/MybbStuff/Core/src/ClassLoader.php(58): require() #1 [internal function]: MybbStuff\Core\ClassLoader->resolve('MybbStuff\\Simpl...') #2 /www/htdocs/w01816eb/storming-gates.de/inc/plugins/MybbStuff/MyAlerts/src/AlertFormatterManager.php(101): spl_autoload_call('MybbStuff\\Simpl...') #3 /www/htdocs/w01816eb/storming-gates.de/inc/plugins/simplelikes.php(651): MybbStuff_MyAlerts_AlertFormatterManager->registerFormatter('MybbStuff\\Simpl...') #4 /www/htdocs/w01816eb/storming-gates.de/inc/plugins/simplelikes.php(614): simpleLikesInitMyAlertsFormatter() #5 /www/htdocs/w01816eb/storming-gates.de/inc/class_plugins.php(142): simpleLikesGlobal('') #6 /www/htdocs/w01816eb/storming-gates.de/global.php(163): pluginSystem->run_hooks(Array) #7 /www/htdocs/w018 in /www/htdocs/w01816eb/storming-gates.de/inc/plugins/MybbStuff/SimpleLikes/src/LikeFormatter.php on line 6


Unfortunately I don't know what else to do. I also uploaded Class Loader, but it didn't change anything. Can you help us?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)