[Pushed] Add A Group Leader Doesn't Put Leader In Usergroup
#1
If you add a person as a group leader in the Admin CP, it does not put the person in the usergroup.  I believe the person should have their additional usergroups updated to be in the usergroup.

Github: https://github.com/mybb/mybb/blob/featur...s.php#L314
Reply
#2
I don't think a group leader has to be in the usergroup he is leading.
[Image: banner.png]
Reply
#3
Why would the person be a group leader then if they aren't in the group? It really doesn't make sense to me.
Reply
#4
(2015-06-09, 10:58 AM)dragonexpert Wrote: Why would the person be a group leader then if they aren't in the group?

i am on the same page as you...
We can't help everyone, but everyone can help someone - Ronald Reagan
Did you know? Your question has already been answered. But you haven't searched it yet.
Don’t  Forget to “Mark as Solved” after the fix
Reply
#5
(2015-06-09, 10:58 AM)dragonexpert Wrote: Why would the person be a group leader then if they aren't in the group? It really doesn't make sense to me.
Common example (used on this forum, too):
You have a usergroup which unlocks a certain section of the forum and (some) team members lead this group. Since the team members have access to the section anyway they don't need to be in the group.

Since not being in the group doesn't affect functionality I wouldn't move users to the group automatically. They probably can add themselves, too.
[Image: banner.png]
Reply
#6
I agree, this would save the admins more time.
Reply
#7
We could add code for joining the usergroup, yes.
Reply
#8
If we add that code we should make it optional (new setting, add leader to group) as that's the behavior since I started using MyBB and as Stefan mentioned some boards may require that the leader isn't in the group.
Support PMs will be ignored!
Reply
#9
I'm the leader of the _journalist_ team in my forum but I'm not part of the team per se, so no, I don't want to, forcedly, be displayed as being part of it thanks.

I don't mind if it is optional.
Reply
#10
Hi,

Thank you for your report. We have pushed this issue to our Github repository for further analysis where you can track our commits and progress with fixing this bug. Discussions regarding this bug may also take place there too.

Follow this link to visit the issue on Github: https://github.com/mybb/mybb/issues/2145

Thanks for contributing to MyBB!

Regards,
The MyBB Group
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)