Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved Whole bunch of issues
Not Solved
Okay, after a year of running an outdated 1.6.12, I finally decided to upgrade to 1.8.5. Now I'm facing some style problems that I'm not really sure what the cause is from. Primarily the read/unread images next to each forum on the index page (strangely enough, the thread list icons are fine), and the buttons under each post for quoting, editing, reporting etc.

I wanted to get a start on fixing these issues, but I've noticed that no matter what change I do in the ACP style editor for the CSS, the source code of the page never changes. The CSS remains the same, before and after saving the changes. At some point, I decided I'll try getting a new theme designed with 1.8 in mind, and just editing the CSS to replicate the old look of my forum, but even this has been unresponsive to ACP changes. The CSS remains exactly as it was when uploaded/imported.

The server does use CloudFlare (unfortunately), so I've tried working around this by using No change. Ctrl F5 has done nothing, and neither has rebuilding the forum caches. I don't have access to CloudFlare, so I can't disable it. In the meantime, I want to explore other options. EDIT: Got CloudFlare disabled, and still no change.

Causes? Solutions? I've tried something as simple as changing the background of the body in the ACP. No luck there. Changing it in the browser with dev tools does work, so I know there's no overriding CSS at work.

(Also, unrelated, but for some reason, this account appears to have been deleted from this site, so I had to register again.)
Not Solved
Have you tried purging the cache within CloudFlare?
Login and go to the Caching tab, scroll down to the Purge Cache section and then click on "Purge Everything".
Not Solved
I haven't, since I don't have access to CF. I asked the person who does control it to disable CF altogether, but it made no difference.

After I woke up, I did see the changes I made last night, so they are being saved. Something must be getting cached though. At least, that's my theory. When I get home, I'll make more changes and see if the problem still persists.

Okay, after making alterations in both the templates and themes, it looks like changes to the template will be seen, while theme changes are not. I removed part of the code in the template, and it disappeared instantly after a normal refresh.

So what could be causing this? Caching can't be the cause, since CloudFlare is now disabled, no cache headers are enabled, and changes are being seen instantaneously for certain actions (template changes). Theme changes so far have only happened after a long period of time, considering that changes made in the theme CSS eventually made it through after I woke up.

Forum Jump:

Users browsing this thread: 1 Guest(s)