Jump to the post that solved this thread.
Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 3 Years, 8 Months, 4 Weeks ago I cannot type in Japanese with MyCode on the message editor
#11
Solved: 3 Years, 8 Months, 4 Weeks ago
(06-23-2015, 12:18 AM)Destroy666 Wrote: That's interesting. Please provide (copy here) the words you're trying to type so that we can test. Also, what's the box with "tab" at the bottom in your .gif which appears when you're typing?  Is it displayed in FF too?

This is the word, (ああああ) what I am trying to type.
Okay, I should explain about Japanese language to answer your question.
Japanese language consists of three different character sets, Kanji(Chinese character), Hiragana, and Katakana.
Hiragana and Katakana are a Japanese syllabary, one basic component of the Japanese writing system.
It is equivalent to the English alphabet and the Hiragana and Katakana character has the 46 standard phonetic characters.
Kanji is the adopted logographic Chinese characters that are used in the modern Japanese writing system along with Hiragana and Katakana.

It is possible to write a sentence by only Hiragana and Katakana. However, the sentence of only Hiragana and Katakana characters will have pauses of words difficult to understand, and will turn into a sentence which is very hard to read. Therefore, Japanese is usually written by using Hiragana, Katakana and Kanji.

The box with tab is the conversion candidates in the conversion system from Hiragana to Kanji or Katakana.
So it displays in all browser when you are using with Japanese Input Method.
I am not sure whether my explanation about Japanese language is clear or not for you. Do you understand what I mean?
Reply
#12
Solved: 3 Years, 8 Months, 4 Weeks ago
Well, if it happens in just one browser - Chrome - it means that there's a bug in that "conversion candidates" box which conflicts somehow with SCEditor. Did you try disabling that box? I doubt we (MyBB) can do anything here.
Reply
#13
Solved: 3 Years, 8 Months, 4 Weeks ago
(06-23-2015, 12:44 PM)Destroy666 Wrote: Well, if it happens in just one browser - Chrome - it means that there's a bug in that "conversion candidates" box which conflicts somehow with SCEditor. Did you try disabling that box? I doubt we (MyBB) can do anything here.

I feel sorry for the late reply.
I googled to try disabling the box for conversion candidates of Japanese, but it is not possible.
Because one Japanese alphabet word needs two alphabet except a vowel.
For example, "KA" (two alphabet) --> "か" (one Japanese alphabet).
"NA" (two alphabet) --> "な" (one Japanese alphabet)
We have 43 Japanese alphabet and 5 vowels.
I cannot do anything to disable that box.....
Reply
#14
Solved: 3 Years, 8 Months, 4 Weeks ago
this happen because of undo plugin.
to solve remove undo plugin...
go to codebuttons template and find :
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/editor_plugins/undo.js?ver=1805"></script>

and remove the line above. Problem solved.

And i will report this issue to sceditor.

Edit: Issue reported to sceditor https://github.com/samclarke/SCEditor/issues/457
Reply
#15
Solved: 3 Years, 8 Months, 4 Weeks ago
(06-24-2015, 02:01 PM)martec Wrote: this happen because of undo plugin.
to solve remove undo plugin...
go to codebuttons template and find :
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/editor_plugins/undo.js?ver=1805"></script>

and remove the line above. Problem solved.

And i will report this issue to sceditor.

Edit: Issue reported to sceditor https://github.com/samclarke/SCEditor/issues/457

Yes!Yes!Yes! The SCEditor works perfectly on my forum after deleting above code as martec told.
Thank you so much for your help to both martec and Destroy666.
Also, much appreciated to reporting this issue on Github for SCEditor, martec.
I hope this error will be fixed with next version of SCEditor.

Thank you.
Reply
#16
Solved: 3 Years, 8 Months, 4 Weeks ago
Thanks for the solution! both of you.

MyBB 1.8.6 Sceditor still has same this IME problem, so I have to give up CTR+Z  ... Sad
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)