Solved: 6 Years, 6 Months, 2 Weeks ago [General] Images
#1
Solved: 6 Years, 6 Months, 2 Weeks ago
Hi can anyone tell me where the images are for this?

[Image: forum.jpeg]

As I've added some of my own links but it's just giving me the magnifying glass

[Image: forum%20new.jpg]

Many thanks
Rusty.
Reply
#2
Solved: 6 Years, 6 Months, 2 Weeks ago
These are packed in a so-called "sprite" image file. In this case it is the /images/headerlinks_sprite.png.

When you want to replace them by others, you have 2 options:
  1. make your own sprite image to replace the existing one. When the individual images remain 20 pixels high, you don't need other changes. Else you also need CSS changes. There is online software for composing sprites.
  2. change the CSS of the links so that they handle single images instead of a sprite.
Regards, Ad Bakker (NL)
Reply
#3
Solved: 6 Years, 6 Months, 2 Weeks ago
Thank-you for the quick reply.

Ok so I've made my own sprite using the link you provided thank-you, I've uploaded that to and replaced the old one but still nothing new.

Do I have to name the images as per the links? so subscription usermap?

This is what I've put in the header templete

<li><a href={$mybb>settings['bburl']}/mysubscriptions.php"title="subscriptions"alt="subscriptions">subscriptions</a></li>

<li><a href="{$mybb->settings['bburl']}/usermap.php" title="usermap" alt="usermap">usermap</a></li>
Reply
#4
Solved: 6 Years, 6 Months, 2 Weeks ago
To be honest I do not completely understand. Did you replace the old headerlinks_sprite.png by a new one?

If so, it can be that it has no direct effect because things are cached. Try:

AdminCP -> Tools & Maintenance -> Cache Manager > Reload & Rebuild All

What you want to achieve wirh these additional lines in the header template I really don't understand. It is probably theme/plugin related? Because mysubscriptions.php and usermap.php are not part of the MyBB core source.
Regards, Ad Bakker (NL)
Reply
#5
Solved: 6 Years, 6 Months, 2 Weeks ago
image icons for the new links need suitable style properties. can we have your forum url so that someone can check ?
Reply
#6
Solved: 6 Years, 6 Months, 2 Weeks ago
.m. has enlightened me Big Grin .
Perhaps it is even sufficient to show the line from the template with the <li> for the Calendar or Memberlist. From that it can be dedused how your additional lines must be composed.
Regards, Ad Bakker (NL)
Reply
#7
Solved: 6 Years, 6 Months, 2 Weeks ago
I have managed to get so far now I've added the following into the Global.css which has allowed the images to show.

#logo ul.top_links a.subscriptions {
background-position: 0 0;
}

#logo ul.top_links a.ausermap {
background-position: 0 -24px;
}

and edited all -px of the other lmages but I am not getting the image for user map to display it just shows the subscriptions image.


Here is a link to my site http://www.vxoc.org.uk/forum/index.php
Reply
#8
Solved: 6 Years, 6 Months, 2 Weeks ago
for the subscriptions link you have to add class subscriptions and for the usermap link you have to add class ausermap

<li><a class="subscriptions" alt="subscriptions" title="subscriptions"  href="$mybb->settings['bburl']}/mysubscriptions.php">subscriptions</a></li>
<li><a class="ausermap" alt="usermap" title="usermap" href="{$mybb->settings['bburl']}/usermap.php">usermap</a></li>
Reply
#9
Solved: 6 Years, 6 Months, 2 Weeks ago
Thank-you both for your help on this and thanks .m. that code worked a treat.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)