Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 4 Years, 2 Months, 2 Weeks ago [General] Thread Prefixes not showing in forum's thread list, but are showing in thread titles?
#1
Solved: 4 Years, 2 Months, 2 Weeks ago
Hi,

Something really wierd to my unmoddified version of MyBB recently.

I set up thread prefixes for an application forum on my site, and they worked for a while, but they now only kind of work.

They do not appear in the thread list: http://gyazo.com/2d0f8f7188f824b6754a521e298fedd8
But they do appear in the thread title when you are viewing the thread: http://gyazo.com/d1dcbb16d8f92b7db145e21165e45df6

Why would this be the case, and how can I fix it.

My site's address is http://www.FactoryLife.co


Any help would be very much appreciated.
Reply
#2
Solved: 4 Years, 2 Months, 2 Weeks ago
This is not an unmodified MyBB version. You clearly use a theme, and themes determine how you view things. So this is a theme matter.
Can you show how template forumdisplay_thread looks like?
Regards, Ad Bakker (NL)
Reply
#3
Solved: 4 Years, 2 Months, 2 Weeks ago
(07-31-2015, 07:40 PM)Ad Bakker Wrote: This is not an unmodified MyBB version. You clearly use a theme, and themes determine how you view things. So this is a theme matter.
Can you show how template forumdisplay_thread looks like?

Hi,

Here's the code for forumdisplay_thread:
<tr class="inline_row">
	<td align="center" class="{$bgcolor}{$thread_type_class}" width="2%"><span class="thread_status {$folder}" title="{$folder_label}">&nbsp;</span></td>
	<td align="center" class="{$bgcolor}{$thread_type_class}" width="2%">{$icon}</td>
	<td class="{$bgcolor}{$thread_type_class}">
		{$attachment_count}
		<div>
          {$GLOBALS['threadfields']['prefix']} <span>{$prefix} {$gotounread}<a href="{$thread['threadlink']}" class="{$inline_edit_class} {$new_class}" id="tid_{$inline_edit_tid}">{$thread['subject']}</a>{$thread['multipage']}</span>
			<div class="author smalltext">Topic started by {$thread['profilelink']}</div>
		</div>
	</td>
	<td align="center" class="{$bgcolor}{$thread_type_class}"></td>
  	{$rating}
	<td align="right" class="{$bgcolor}{$thread_type_class}" width="15%">Views {$thread['views']} <br /> Replies <a href="javascript:MyBB.whoPosted({$thread['tid']});">{$thread['replies']}</a>{$unapproved_posts}</td>
	<td class="{$bgcolor}{$thread_type_class}" style="white-space: nowrap; text-align: left;">
		<span class="lastpost smalltext">{$lastpostdate}<br />
		<a href="{$thread['lastpostlink']}">{$lang->lastpost}</a>: {$lastposterlink}</span>
	</td>
{$modbit}
</tr>

Thanks, again, for your help.
Reply
#4
Solved: 4 Years, 2 Months, 2 Weeks ago
Try changing this line:


{$GLOBALS['threadfields']['prefix']} <span>{$prefix} {$gotounread}<a href="{$thread['threadlink']}" class="{$inline_edit_class} {$new_class}" id="tid_{$inline_edit_tid}">{$thread['subject']}</a>{$thread['multipage']}</span>

into:

{$GLOBALS['threadfields']['prefix']} <span>{$prefix} {$gotounread}{$thread['threadprefix']}<a href="{$thread['threadlink']}" class="{$inline_edit_class} {$new_class}" id="tid_{$inline_edit_tid}">{$thread['subject']}</a>{$thread['multipage']}</span>
Regards, Ad Bakker (NL)
Reply
#5
Solved: 4 Years, 2 Months, 2 Weeks ago
(07-31-2015, 08:29 PM)Ad Bakker Wrote: Try changing this line:


{$GLOBALS['threadfields']['prefix']} <span>{$prefix} {$gotounread}<a href="{$thread['threadlink']}" class="{$inline_edit_class} {$new_class}" id="tid_{$inline_edit_tid}">{$thread['subject']}</a>{$thread['multipage']}</span>

into:

{$GLOBALS['threadfields']['prefix']} <span>{$prefix} {$gotounread}{$thread['threadprefix']}<a href="{$thread['threadlink']}" class="{$inline_edit_class} {$new_class}" id="tid_{$inline_edit_tid}">{$thread['subject']}</a>{$thread['multipage']}</span>

Thank you very much for that - extremely helpful!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)