Jump to the post that solved this thread.
Solved: 6 Years, 2 Months, 3 Weeks ago [Error Message] SQL Error: 1146, after restoring
#1
Solved: 6 Years, 2 Months, 3 Weeks ago
Hi, before everything worked fine but when we restored all the files and SQL database at the new location we get the error

MyBB SQL Error

MyBB has experienced an internal SQL error and cannot continue.
SQL Error:1146 - Table 'compucoi_focc913.focc_sessions' doesn't exist

Can anyone please help?

Forum: http://forum.compucoins.com/index.php
Reply
#2
Solved: 6 Years, 2 Months, 3 Weeks ago
basically ~/inc/config.php file should have correct database details
$config['database']['type'] = '______';
$config['database']['database'] = '______';
$config['database']['table_prefix'] = '______';

$config['database']['hostname'] = '______';
$config['database']['username'] = '______';
$config['database']['password'] = '______';

also ensure that sessions table physically exists in the database (check through database manager eg. phpMyAdmin)
Reply
#3
Solved: 6 Years, 2 Months, 3 Weeks ago
Did you have a look with phpMyAdmin to see whether the sessions table of your forum exists?
Regards, Ad Bakker (NL)
Reply
#4
Solved: 6 Years, 2 Months, 3 Weeks ago
(2015-08-02, 10:56 AM).m. Wrote: basically ~/inc/config.php file should have correct database details
$config['database']['type'] = '______';
$config['database']['database'] = '______';
$config['database']['table_prefix'] = '______';

$config['database']['hostname'] = '______';
$config['database']['username'] = '______';
$config['database']['password'] = '______';

also ensure that sessions table physically exists in the database (check through database manager eg. phpMyAdmin)

Thanks. The config are fine, all entries are correct. phpMyAdmin shows 36 tables, sessions only "focc_adminsessions"

(2015-08-02, 10:58 AM)Ad Bakker Wrote: Did you have a look with phpMyAdmin to see whether the sessions table of your forum exists?

Thanks. Yes I did but there is only a "focc_adminsessions" out from 36 tables in total.
Reply
#5
Solved: 6 Years, 2 Months, 3 Weeks ago
^ looks like your database backup is not complete. do you have forums, posts, threads, and users tables with the data ?
Reply
#6
Solved: 6 Years, 2 Months, 3 Weeks ago
(2015-08-02, 11:38 AM).m. Wrote: ^ looks like your database backup is not complete. do you have forums, posts, threads, and users tables with the data ?

Yes you are right. Our new host www.site5.com fixed all issues, thanks to all for their attention!
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)