Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 3 Years, 3 Months, 1 Week ago 403 Forbidden Error
#1
Solved: 3 Years, 3 Months, 1 Week ago
Forum URL: http://scifi-network.newagesoldier.com

Okay, after I fixed this error and got my forum working again I have been getting hit with 403 Forbidden Errors or other permission errors when I:
  • Try to edit a Super Admin's Permissions (even though my uid is listed in inc/config.php) it keeps giving me an error saying to add my uid to inc/config.php if I want to edit my own permissions.
  • Try to edit another user's profile via Admin CP > Users & Groups > Users. Get hit with a 403 error telling me I don't have access to admin/index.php.
  • Try sending private messages with urls or other special characters (private messages without urls work fine as do replies to existing private messages)
  • Try editing primary templates (Header, Member_Profile, Portal, Postbit_Classic, etc.) Though, to be fair most other templates can be edited just fine.
I'm not sure exactly what permissions are supposed to be set, but I'm sure they haven't been modified. Anyone know how to fix this?

Edit: Okay I am positive everything is CHMOD correctly but still no luck.

I've also checked the PHP Info in the Tools & Maintenance and I can't find mod_security under 'Additional Modules' the only thing listed there is ionCube Loader. So I'm not exactly sure mod_security (if its even installed) is causing the issue.

Also I've triple-checked (just to be sure) my PHP Version and I can confirm it to be 5.3 and not 5.4 like I originally thought. 

Any further help is appreciated Smile
Reply
#2
Solved: 3 Years, 3 Months, 1 Week ago
contact your web host and ask to disable any additional security they have put in (eg. mod_security / suhosin ..)
Reply
#3
Solved: 3 Years, 3 Months, 1 Week ago
My host hasn't responded yet so I can't really do anything further until he does.

Also, I have updated the first post. Hope it clarifies my problem a bit more.

Thanks again in advance! Toungue
Reply
#4
Solved: 3 Years, 3 Months, 1 Week ago
Strange!!
I see this is a 1.8.05 installation, did you run "File Verification" from AdminCP -> Tools & Maintenance?
Regards, Ad Bakker (NL)
Reply
#5
Solved: 3 Years, 3 Months, 1 Week ago
(08-10-2015, 08:57 PM)Ad Bakker Wrote: Strange!!
I see this is a 1.8.05 installation, did you run "File Verification" from AdminCP -> Tools & Maintenance?

Yep. The ones I modified myself were listed in the results as "Changed" and I replaced them with the ones from the MyBB 1.8.5 installation and got the same result.

Also a little update to the editing users in the admin panel -- only 5 out of 17 members generate the 403 Forbidden Error.
Reply
#6
Solved: 3 Years, 3 Months, 1 Week ago
I have further no idea. Let's hope that .m. has, when he has had his deserved night rest.

I hope you will succeed, I am a SF (books) fan since 1960 and have read at least 3000, still have some 1500 here on the shelf.
Regards, Ad Bakker (NL)
Reply
#7
Solved: 3 Years, 3 Months, 1 Week ago
(08-10-2015, 09:19 PM)Ad Bakker Wrote: I have further no idea. Let's hope that .m. has, when he has had his deserved night rest.

I hope you will succeed, I am a SF (books) fan since 1960 and have read at least 3000, still have some 1500 here on the shelf.

Thanks @Ad Bakker that means a ton! Glad to see another fellow Science Fiction fanatic amongst us fellow MyBBers!

Anywhoo thanks for trying. Its appreciated! Smile

Update: When I attempted to edit a custom .css file I got the following error:

Not Acceptable!

An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security.

This was the only time an error message appeared relating to Mod_Security.

I have the code to block mod_security in my .htaccess file. Any other solutions to this? I'm using the method here and it's apparently not working any longer.
Reply
#8
Solved: 3 Years, 3 Months, 1 Week ago
Update!

Okay, so I no longer have 403 Forbidden Errors on my site and I have access to most of it however I am still getting the mod_security error when I attempt to modify or add custom stylesheets. This does not occur on stylesheets like global.css only on custom stylesheets.

Anyone have a fix for this?
Reply
#9
Solved: 3 Years, 3 Months, 1 Week ago
^ if code in htaccess is not effective then its better to get your site white listed from mod_security rules by web host
Reply
#10
Solved: 3 Years, 3 Months, 1 Week ago
(08-15-2015, 03:21 AM).m. Wrote: ^ if code in htaccess is not effective then its better to get your site white listed from mod_security rules by web host

Have contacted host about this already, haven't gotten a response. Regardless, seems like the best solution.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)