Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 4 Years, 1 Month, 4 Weeks ago Use Same Database For New Forum
#1
Solved: 4 Years, 1 Month, 4 Weeks ago
I want to use a 1.8.5 MyBB database for another, new 1.8.5 MyBB forum.

So I have the database from the first site and I've imported it via PHPmyAdmin into the database for the second site.

Next, I uploaded the 1.8.5 files into the new domain name's folder and changed the database details in the inc/config.php files - database user, database name and password.

When I go the website, the page is blank, so I am missing a value somewhere?  Are there other paths somewhere else that I need to change?

Ideas, please?

Is there another files with paths, etc.? that I have to change?
Reply
#2
Solved: 4 Years, 1 Month, 4 Weeks ago
Did you login in AdminCP and then changed the database details also in Configuration(settings)-> Site Details (don't forget to save!!).
Regards, Ad Bakker (NL)
Reply
#3
Solved: 4 Years, 1 Month, 4 Weeks ago
(08-12-2015, 05:07 PM)Ad Bakker Wrote: Did you login in AdminCP and then changed the database details also in Configuration(settings)-> Site Details (don't forget to save!!).


Here's the problem:

When I use the same database from site A to site B, I can't login to site B - the admin screen is blank.

If those values in Configuration> Settings via the Admin panel can't be changed through a file edit via FTP or PHPmyAdmin, that poses a problem.

By the way, thanks for all of you help with my various issues!
Reply
#4
Solved: 4 Years, 1 Month, 4 Weeks ago
(08-12-2015, 06:37 PM)themuttfactor Wrote: Here's the problem:

When I use the same database from site A to site B, I can't login to site B - the admin screen is blank.

If those values in Configuration> Settings via the Admin panel can't be changed through a file edit via FTP or PHPmyAdmin, that poses a problem.

By the way, thanks for all of you help with my various issues!


Where did you get the idea that configuration settings and settings, in general, can't be edited through phpmyadmin? Of course they can be edited. Otherwise, where would they be stored? You've looked at the mybb_settings table, right?

Do your php error logs say anything?

Also double check to make sure all files were uploaded correctly because sometimes FTP fails to upload 100% of files.

If the forum domain changed you will have to edit cookie settings also.
Find me here or at my new blog about MyBB, Web Design, SEO
My Services
MyBB Themes
Reply
#5
Solved: 4 Years, 1 Month, 4 Weeks ago
(08-12-2015, 10:49 PM)ThemeFreaknet Wrote:
(08-12-2015, 06:37 PM)themuttfactor Wrote: Here's the problem:

When I use the same database from site A to site B, I can't login to site B - the admin screen is blank.

If those values in Configuration> Settings via the Admin panel can't be changed through a file edit via FTP or PHPmyAdmin, that poses a problem.

By the way, thanks for all of you help with my various issues!


Where did you get the idea that configuration settings and settings, in general, can't be edited through phpmyadmin? Of course they can be edited. Otherwise, where would they be stored? You've looked at the mybb_settings table, right?

Do your php error logs say anything?

Also double check to make sure all files were uploaded correctly because sometimes FTP fails to upload 100% of files.

If the forum domain changed you will have to edit cookie settings also.

I didn't write that it can't be edited, I wrote if.  At any rate, your suggestion above solved the problem, so THANK YOU  Cool 

I've learned something new that I can share.

The only problem that I have to now solve is that the front page of the site is off, like it needs the cache to be rebuilt or something....I can log into the admin panel, but when I click any link, it logs me right out.

Ideas?
Reply
#6
Solved: 4 Years, 1 Month, 4 Weeks ago
This link will help you with login / log out "cookie" issues:
http://community.mybb.com/thread-126359.html

In short, if you changed domains, your cookie settings will need to be changed. Clear cookies and try to log back in.
Find me here or at my new blog about MyBB, Web Design, SEO
My Services
MyBB Themes
Reply
#7
Solved: 4 Years, 1 Month, 4 Weeks ago
Helped immensely - thanks! Smile
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)