Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 6 Years, 1 Month, 3 Weeks ago [Upgrading] trying to upgrade board - massive sql errors
#1
Solved: 6 Years, 1 Month, 3 Weeks ago
I am upgrading a board for someone. He was using 1.6.10 and wanted to go to 1.8+

did all the usual backing up etc and did the upgrade.
Everything seemed to be ok except for his default theme. It broke. The added on one seemed fine.

So, I tried fiddling around to no avail and I went and tried again from scratch. I also remembered I forgot to turn off all the plugins so this time I did that.

Then I went and upgraded to 1.6.17 first and this seemed to fix the theme issue but he has a bad plugin in there that is causing major issues with the site and I just don't know how to fix this.

I want to fix this so I can upgrade to 1.8 for him but I'm lost. I realize that 1.6 is no longer supported but we need this fixed before I can go and upgrade.

Uninstalling the plugin isn't an option for me since it does not have an uninstall feature and I don't know enough about databases to go removing things.

It's the last visitors in profile plugin- http://mods.mybb.com/view/last-visitors-in-profile

A quick browse of the plugin support didn't show any of the error issues i'm having with this.
The author has no link for direct support.

These are the errors that is being thrown:

This one happens on any change you want to make in the UserCp

SQL Error:
1054 - Unknown column 'longlastip' in 'field list'
Query:
UPDATE mybb_users SET lastvisit='1440767105', lastactive='1440770810', lastip='96.242.173.231', longlastip='1626516967' WHERE uid='525'

This one happens if I try to make a post and hit send:

MyBB has experienced an internal SQL error and cannot continue.
SQL Error:
1054 - Unknown column 'longipaddress' in 'field list'
Query:
INSERT INTO mybb_posts (`tid`,`replyto`,`fid`,`subject`,`icon`,`uid`,`username`,`dateline`,`message`,`ipaddress`,`longipaddress`,`includesig`,`smilieoff`,`visible`) VALUES ('2324','13168','15','RE: Major forum changes','0','525','Webmaster','1440770968','Some things are broken. \r\n\r\nThe board is somewhat upgraded, but navigating around and some theme elements are gone. There is a bad plugin that is causing database issues that I just have no clue how to resolve. \r\n\r\nIt\'s causing time outs for the admin panel and if anyone wants to visit a thread directly from the links on the right side of the home page, it\'s throwing the error. \r\n\r\nTo get around this you either have to use the back button on your browser and refresh to see if the changes took place or as in the case of threads, you have to go in the \"long way\" by clicking the forum, then the thread title and scrolling down. \r\n\r\nI\'m hoping my post doesn\'t throw the error when I hit send.\r\n\r\nPLEASE be patient and I\'ll get this sorted as soon as I can.','96.242.173.231','1626516967','0','0','1') 

Admin sessions are constantly timing out as well. When I click a page to do something, I'm logged out. Its telling me the IP address is problem. I have to use TOR browser to work in there for now, but it still bumps me out and I have to log in again.

There probably are more broken plugins here as well.

I need to get him working again. Right now I have his site down.
#2
Solved: 6 Years, 1 Month, 3 Weeks ago
if you have searched around the forums, you might have seen similar threads with the possible solutions (eg.) ...
#3
Solved: 6 Years, 1 Month, 3 Weeks ago
Thanks.


Forum Jump:


Users browsing this thread: 1 Guest(s)