Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved Need help with Forum Stretching
#1
Not Solved
Hi all,

First of all let me inform anyone reading this i am a complete noob when it comes to websites and so on, someone i know made a PHP forum for my server community to use and hosted it, that person however has now taken down that forum and will no longer host it, i have lost months of data/info and am unable to pay a professional to provide one for me.

However i am fairly determined and trying to do this on my own, having watch hours and hours of tutorials (Which sometimes confuse me even more) i ended up downloading some themes to try and find something that fits with the community.

I then wanted to edit that theme to incorporate my own server communities banner and background which i have successfully done, and starting to get all excited with myself i previewed the forum each time i made changes/edits and it looked perfect and like this.

[Image: GJ3XfIB.jpg]

However when someone else comes to the forum and registers, once they are logged in the forums change to this (This also applies to me when i login from the URL as you can see in the 2nd image)

[Image: Ac3C0Je.jpg]

I am at a loss as to what to do, having read through many threads on here, i have not found anything describing this problem, and also quite importantly i see most replies to questions involve "ok what you need to do is edit the SomethingSomthing, and enter the code for something something" which generally involves a lot of code i have no idea how to implement.

Basically my knowledge of HTML is essentially putting [IMG] infront and behind an image link and the codes for a couple of colours.

If anyone has the time and inclination to help an incredibley poor forum builder and is able to explain it in very basic and clear terms to me what exactly i need to do i would be extremely grateful of their time.

Thanks in advance and hopefully there is a kind soul out there not too busy laughing at my post and able to help in some way  Smile

Regards

Reggie
Reply
#2
Not Solved
This user has been denied support. This user has been denied support.
So you broke the "container" div. I'm guessing you have too many "</div>" in your header_welcomeblock_member.

Post the contents of header_welcomeblock_member. Can be found by following the below breadcrumbs:

AdminCP > Templates & Styles > Templates (on the left sidebar) > "Your current theme" > Header Templates > header_welcomeblock_member

BE SURE TO PLACE THE CONTENTS INSIDE [CODE] TAGS ON HERE!

Please include the URL of your forum as well.

Thanks!
-Sparkks
Reply
#3
Not Solved
Hi Sparkks,

Thank you for your reply, here is the information you asked for i think, will this also be needed for the header_welcomeblock_member_admin/moderator too? or if the guest header is working, could i just copy what is in there to the member, admin and moderator ones??

<!-- Continuation of div(class="upper") as opened in the header template -->
	<span class="welcome">{$lang->welcome_back} <a href="{$mybb->settings['bburl']}/member.php?action=logout&amp;logoutkey={$mybb->user['logoutkey']}" class="logout">{$lang->welcome_logout}</a></span>
	</div>
</div>
<div class="lower">
	<div class="wrapper">
		<ul class="menu panel_links">
			<li><a href="{$mybb->settings['bburl']}/usercp.php" class="usercp">{$lang->welcome_usercp}</a></li>
			{$modcplink}
			{$admincplink}
		</ul>
		<ul class="menu user_links">
			<li><a href="#" onclick="MyBB.popupWindow('{$mybb->settings['bburl']}/misc.php?action=buddypopup&modal=1', null, true); return false;">{$lang->welcome_open_buddy_list}</a></li>
			<li><a href="{$mybb->settings['bburl']}/search.php?action=getnew">{$lang->welcome_newposts}</a></li>
			<li><a href="{$mybb->settings['bburl']}/search.php?action=getdaily">{$lang->welcome_todaysposts}</a></li>
			<li><a href="{$mybb->settings['bburl']}/private.php">{$lang->welcome_pms}</a> {$lang->welcome_pms_usage}</li>
		</ul>
	</div>
	<br class="clear" />
</div>

there you go, and thanks for your time, the website URL is in the screenshots above.

Thanks

Reggie
Reply
#4
Not Solved
This user has been denied support. This user has been denied support.
(08-28-2015, 11:21 PM)FLC Reggie Wrote: Hi Sparkks,

Thank you for your reply, here is the information you asked for i think, will this also be needed for the header_welcomeblock_member_admin/moderator too?  or if the guest header is working, could i just copy what is in there to the member, admin and moderator ones??

<!-- Continuation of div(class="upper") as opened in the header template -->
 <span class="welcome">{$lang->welcome_back} <a href="{$mybb->settings['bburl']}/member.php?action=logout&amp;logoutkey={$mybb->user['logoutkey']}" class="logout">{$lang->welcome_logout}</a></span>
 </div>
</div>
<div class="lower">
 <div class="wrapper">
 <ul class="menu panel_links">
 <li><a href="{$mybb->settings['bburl']}/usercp.php" class="usercp">{$lang->welcome_usercp}</a></li>
 {$modcplink}
 {$admincplink}
 </ul>
 <ul class="menu user_links">
 <li><a href="#" onclick="MyBB.popupWindow('{$mybb->settings['bburl']}/misc.php?action=buddypopup&modal=1', null, true); return false;">{$lang->welcome_open_buddy_list}</a></li>
 <li><a href="{$mybb->settings['bburl']}/search.php?action=getnew">{$lang->welcome_newposts}</a></li>
 <li><a href="{$mybb->settings['bburl']}/search.php?action=getdaily">{$lang->welcome_todaysposts}</a></li>
 <li><a href="{$mybb->settings['bburl']}/private.php">{$lang->welcome_pms}</a> {$lang->welcome_pms_usage}</li>
 </ul>
 </div>
 <br class="clear" />
</div>

there you go, and thanks for your time, the website URL is in the screenshots above.

Thanks

Reggie

Can you send me a test account.
-Sparkks
Reply
#5
Not Solved
hi,

how do i send a test account? and also would i just copy/paste the settings from the guest account over to the member/moderator/admin account

Also i didn't change anything from the header or anything else like that after downloading the theme, the only things i changed were the banner at the top and the background picture in "Body" i added my own background image, saw the path that was currently set for the original background and just put my chosen background there, and changed the name of the "background" info in the body area of global .css to point to the new image.
Reply
#6
Not Solved
can you give the link of the theme you are using ..
looks like incompatible theme is used on MyBB 1.8.x forum.
Reply
#7
Not Solved
hi,

http://mods.mybb.com/view/fansite-diablo3-v1

That isnt actually the place i originally downloaded it from, i cant actually find the original place i downloaded it from but thats definitely the theme there.

I went for that one after downloading quite a few other free ones as it matches the colouring i wanted.

Thanks
Reply
#8
Not Solved
^ that theme is not compatible with MyBB 1.8.x.
good amount of time & efforts required for making it suitable for MyBB 1.8.x

so its better to use a compatible theme for your forum.
MyBB 1.8.x compatible themes => http://community.mybb.com/mods.php?actio...ory=themes

theme installation guidance (if required) => http://community.mybb.com/thread-163256.html
Reply
#9
Not Solved
Hi .m.

Ok so i changed the theme to one of the ones you linked, it still says its incompatible, but i ticked the box to ignore, it works well apart from the banner i applied not being in the right place, ideally i would like it in line with the rest of the forum column and either remove or move the search bar that would be in the way if the banner is in the centre?

I would also like to add another couple of area's on the right side on the index page of the forums that currently just has "Latest News" Auction house coming soon, preferably so i can get a TS widget thingy in there too below the "Latest news" one and maybe 1 more area for other info.

sorry for being such a noob, i just cannot afford to pay a professional Sad

www.flc.clanservers.com is the forum location if anyone is able to help and advise.

Cheers

Reggie
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)