Jump to the post that solved this thread.
Solved: 5 Years, 5 Months, 1 Week ago Help Documents
#1
Solved: 5 Years, 5 Months, 1 Week ago
For some reason, when create new section and documents for the Help Doc page, and changed their ID (via PhpMyAdmin) to 1,2,..., it shows the default help section.

[Image: 2Uz8I6J.png]

[Image: wcCl4MC.png]
just a noob.
Reply
#2
Solved: 5 Years, 5 Months, 1 Week ago
I recommend that you use the Admin CP rather than change things directly in the database. Some parts of MyBB actually rewrite the php files and unless you modify your settings through the Admin CP, the scripts that update the files do not run.

This may not be the problem in your case, but it is a possibility.

I would change things back via PhpMyAdmin and then try adjusting your settings via Admin CP. If that does not fix the issue, you might try rebuilding the cache.
Reply
#3
Solved: 5 Years, 5 Months, 1 Week ago
If I use the admin cp, the Document and Section ID will be somewhere around 60-70.
just a noob.
Reply
#4
Solved: 5 Years, 5 Months, 1 Week ago
What is the ID of the "Important Documentations" section?
XThreads App For MyBB: Link Directory, YouTube Gallery & etc - Full List
My Demo Site
Reply
#5
Solved: 5 Years, 5 Months, 1 Week ago
(2015-09-24, 09:35 PM)nollidnosnhoj Wrote: If I use the admin cp, the Document and Section ID will be somewhere around 60-70.

I do not see how this is a problem.  I assume you are concerned about the order in which they are displayed, and the ID number has nothing to do with that.  For example, "Markup" is ID #3, but appears in position #1 not only in Admin CP but also in my forum.

1.  Admin CP --> Configuration
2.  "Help Documents" Left Menu
3.  Click "Edit" on the document you want.
4.  Under "Display Order" enter the desired position.


Attached Files Thumbnail(s)
           
Reply
#6
Solved: 5 Years, 5 Months, 1 Week ago
@nollidnosnhoj:
MyBB 1.8 forces the usetranslation. So all default Sections (ID 1 and 2) and Documents (ID 1 - 7) use the language files. It makes whatever you do with the Title, Short Description and Document of those Sections (ID1 and 2) and Documents (ID 1 - 7) won't make any impact (for new installation).

Hopefully you know what you should do with the explanation.
XThreads App For MyBB: Link Directory, YouTube Gallery & etc - Full List
My Demo Site
Reply
#7
Solved: 5 Years, 5 Months, 1 Week ago
(2015-09-24, 09:54 PM)RateU Wrote: What is the ID of the "Important Documentations" section?

It's 1.

(2015-09-24, 09:55 PM)Dexie Wrote:
(2015-09-24, 09:35 PM)nollidnosnhoj Wrote: If I use the admin cp, the Document and Section ID will be somewhere around 60-70.

I do not see how this is a problem.  I assume you are concerned about the order in which they are displayed, and the ID number has nothing to do with that.  For example, "Markup" is ID #3, but appears in position #1 not only in Admin CP but also in my forum.

1.  Admin CP --> Configuration
2.  "Help Documents" Left Menu
3.  Click "Edit" on the document you want.
4.  Under "Display Order" enter the desired position.

It's not really the order, but the ID. I want the URL of the help doc to start with 1 instead of 78 or something that high.

(2015-09-24, 10:23 PM)RateU Wrote: @nollidnosnhoj:
MyBB 1.8 forces the usetranslation. So all default Sections (ID 1 and 2) and Documents (ID 1 - 7) use the language files. It makes whatever you do with the Title, Short Description and Document of those Sections (ID1 and 2) and Documents (ID 1 - 7) won't make any impact (for new installation).

Hopefully you know what you should do with the explanation.

So basically change the language files? I will see what I can do.

Alright got it to work. I edited the language files for the help sections. What also works is disabling (changing the value to 0) in the usetranslation option in the helpdocuments database.

I know this is solved, but i was wondering if there's a way to force the value of 'usetranslation' to 0
just a noob.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)