Not Solved Unable to run install script
#1
Not Solved
I've upgraded one forum successfully.

I'm now upgrading a second forum and have a problem.

When I run the installation wizard I get the following error.

Warning [2] Invalid argument supplied for foreach() - Line: 67 - File: inc/cachehandlers/memcache.php PHP 5.2.12 (Linux)

Just guessing - does this mean I need to disable memcache?

(and how would I do that?)


EDIT TO ADD:
It also says - Warning [2] Cannot modify header information - headers already sent by (output started at /home/babevide/public_html/inc/class_error.php:229) - Line: 1861 - File: inc/functions.php PHP 5.2.12 (Linux)
And - Warning [2] MemcachePool::get() [memcachepool.get]: Failed to extract 'connection' variable from object - Line: 106 - File: inc/cachehandlers/memcache.php PHP 5.2.12 (Linux)

I get as far as the page where you login as administrator - it won't accept a login.

EDIT TO FURTHER ADD: I've just noticed that the error.php:229 message doesn't seem anything to do with memcache.


[Image: image-D5F4_560652A1.jpg]

[Image: image-BCB7_56065C95.jpg]



EDIT AGAIN to say that I reverted the forum back to 1.4 and that worked perfectly. I was a bit nervous about how it would work out, but I had all the files backed up and was able to restore them without any problems. So I'm now back to 1.4 and running OK. Also, I created a sub-directory and made a test install and that worked perfectly too. No sign of the previous problems with this fresh install.

So in summary I have a forum version 1.4 which I can't upgrade, for reasons I can't fathom, but I have a fresh 1.8.6 install on a sub-directory on the exact same server/domain.
Reply
#2
Not Solved
Check this: http://stackoverflow.com/questions/12062...e-with-php You most likely forgot to fill in connection details for memcache in inc/config.php. Or they're wrong.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)