Solved: 5 Years, 11 Months, 3 Weeks ago [Error Message] Random posts cannot be edited
Solved: 5 Years, 11 Months, 3 Weeks ago
Background info:

I recently ported a small forum of mine from to myBB. In order to do this, I had to install both SMF and myBB locally, convert the database to SMF, and then run a merge to get everything onto myBB before uploading the forum to my hosting. The only way I was able to do this successfully was to convert all of the BBcode to html. For whatever reason, if I did not do this, posts would not port correctly and would end up half gone. Because of this, I need to leave HTML enabled for posts on my forum, or else the formatting gets completely ruined for posts that are sometimes very complicated.

I have no idea if any of those things are actually relevant, but I thought I should mention it, just in case.

Seemingly at random, my attempts to edit posts - regardless of the original author - result in a 'forbidden' error telling me that I am not allowed to access editpost.php. Often, I can edit the surrounding posts without issue. This occurs even with all plugins disabled.

Even stranger: because I had to do all the converting and merging on my local system, I still have a very recent copy of essentially the entire forum on my PC. When I access the local version of the forum, I can edit those same posts. I have even gone so far as to attempt to edit the message field directly in phpmyadmin, but even then, the changes do not save and the page remains 'loading' indefinitely.

An example of a post I cannot edit is this one. I am able to edit every other post on the page, and there is no difference that I can detect between that post and the others. It should be identical to the one I have locally, and yet I can edit the local version, and not that one.

Am I missing something obvious? This is one of the only issues I've had thus far that I have not been able to sort out on my own.
Solved: 5 Years, 11 Months, 3 Weeks ago
For posterity: I found the solution to my problem! It was not anything involving myBB or the database at all. In fact, the issue was entirely on the server side of things. I needed to disable Apache's Mod Security addon under cPanel. Once I did that, everything started to work fine. The solution was found after a user discovered that the issue was impacting new replies, as well as post edits.

Forum Jump:

Users browsing this thread: 1 Guest(s)