Solved: 5 Years, 5 Months, 2 Weeks ago [JavaScript] Quick Reply Spinner
#1
Solved: 5 Years, 5 Months, 2 Weeks ago
A weird problem here. I make a quick reply and it works, except the small spinner keeps spinning, but once I refresh the page, it's gone and the quick reply has been posted successfully.

I have this in my header for my drops downs:
<script type="text/javascript">
// <!--
    if(use_xmlhttprequest == "1")
    {
        $("#extraslink").popupMenu();
        $("#userlink").popupMenu();
    }
// -->
</script>


Now, when I add $.noConflict(); under the userlink code, the quick reply works as normal, and no spinner is there. However, it stops me from using the collapse on my tables and it then interferes with this code I have for my index sidebox:

<script type="text/javascript">
jQuery(function(){
jQuery(".latestthreads").load("{$mybb->settings['bburl']}/portal.php .latestthreads_portal");
jQuery(".lateststats").load("{$mybb->settings['bburl']}/portal.php .lateststats"); 
jQuery(".whosonline").load("{$mybb->settings['bburl']}/portal.php .whosonline"); 
}); </script>

So, without the noConflict code, the spinner keeps spinning, but the collapse and index side box code works. Is there anything I can do to fix this?
Reply
#2
Solved: 5 Years, 5 Months, 2 Weeks ago
I also have this problem, however I have bootstrap css and js in my headerinclude, and assumed it was due to that somehow.
What goes around comes around
Reply
#3
Solved: 5 Years, 5 Months, 2 Weeks ago
There's currently a bug that *might* be causing this, but I'm not 100% sure that it causes this specific behavior.
PGP Key (Fingerprint: 23B6 F4C0 FE2D 45AA 61A0 1E86 DB87 09DC DD87 6E40)
Reply
#4
Solved: 5 Years, 5 Months, 2 Weeks ago
How do we find out if it is a bug Josh? The quick reply spinner has the hidden class, so I assumed that it would not be seen, but it is.

I have the same Ashley.
Reply
#5
Solved: 5 Years, 5 Months, 2 Weeks ago
I just took a look and it doesn't seem like this is at all connected to the issue I was thinking of. Could I get a board URL and (preferably) testing account to debug this issue? Feel free to PM the information to me if you want to keep it private.
PGP Key (Fingerprint: 23B6 F4C0 FE2D 45AA 61A0 1E86 DB87 09DC DD87 6E40)
Reply
#6
Solved: 5 Years, 5 Months, 2 Weeks ago
I'm actually making a new theme, so it's all on localhost. I unfortunately can't give you any test details. I was just making a theme and testing it out myself.
Reply
#7
Solved: 5 Years, 5 Months, 2 Weeks ago
I PM'd a test account.

I replaced my showthread_quickreply template with one from the vanilla install, and the problem disappears (that's with the bootstrap css and js and all other mods still in place). I am still trying to see where I went wrong, if i find something I will report back.
What goes around comes around
Reply
#8
Solved: 5 Years, 5 Months, 2 Weeks ago
Did you get this sorted Ashley1? Were you able to check this out Josh?
Reply
#9
Solved: 5 Years, 5 Months, 2 Weeks ago
(2015-10-20, 09:35 PM)J Greig Wrote: Did you get this sorted Ashley1? Were you able to check this out Josh?

Hi, Josh did offer to look into this round about tomorrow, but I don't think there's any bug, as described above. Did you replace your template just to see if it makes a difference. Mine works with the stock file.
What goes around comes around
Reply
#10
Solved: 5 Years, 5 Months, 2 Weeks ago
I am assuming it's to do with the code listed in the OP. As I say, once I add noConflict to the header dropdown javascript, it runs as normal. But once I do that, the javascript on my index page (which pulls latest threads etc from portal) stops working.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)