Registration problems
#1
HI,  I just heard from someone trying to register who was having problems; In checking it out there are several issues that I can see.

It is set to "send a random password" in admin, but I don't think that message is conveyed when the person tries to register, unless a message comes up after or if the registration is successful.

The option in the Admin panel for changing the basic security question is not available so it's still at the default 2+2, which reading, is not a good idea. There is no way to update with the old plugin that is now written into the program for changing that.

There is supposed to be a recaptcha image , but there is no image and it says, image verification--invalid site key. IN admin it shows both the private and public keys.

I am not sure what to do, and checked that the option of changing to email verification-- which did change the registration options to show where passwords could be entered. But that didn't correct the recaptcha image issue.

Any ideas?
Reply
#2
The registration question and security question plugins stored the questions / answers in a different db table. On upgrading to MyBB 1.8, I copied from the old table to the new one (it even maintained the correct / total counts). I am not where I can verify the names of the tables.
Reply
#3
(2015-12-01, 08:35 PM)laie_techie Wrote: The registration question and security question plugins stored the questions / answers in a different db table. On upgrading to MyBB 1.8, I copied from the old table to the new one (it even maintained the correct / total counts). I am not where I can verify the names of the tables.

I get what you are talking about, but I don't know anything about the db tables.
This is where explicit directions and information are needed, because this is beyond what I know as yet. But willing to learn if there's a way to fix it. Had another email from someone else who had tried to register and mentioned the recaptcha image isn't there.

I forgot to mention that I am using Vienna theme. And I have not upgraded from mybb 8.5 yet, if any of that makes any difference.
Reply
#4
OK, I went through the templates about member register regimage etc, and found one discrepancy between the default template and Vienna theme template. But it made no difference.

So went to Google recaptcha and it says I don't have a key even though I do/did have the keys, but there is a new version. So reregistered, and got keys but it says to do this:

Paste this snippet before the closing </head> tag on your HTML template:
<script src='https://www.google.com/recaptcha/api.js'></script>
Paste this snippet at the end of the <form> where you want the reCAPTCHA widget to appear:
<div class="g-recaptcha" data-sitekey= and the key is here

But because this isn't just an html website but a MYBB forum---where and how do I put those in? IN the Vienna theme templates?

Does anybody use recaptcha here? and has had to do this?

It's not that I am not trying very hard to fix this---but I don't want to mess it up and do it wrong. Especially with the nightmare to upgrade the last time.

Any help very much appreciated.

It doesn't resolve the missing Configuration: security question  issue but it's a start.

I guess I am doing better than I thought. I did another backup of my database and then again tried to register---the recaptcha image is now there and appears to work, although the image box is too big for the theme.

However, next issue. How do I fix the missing Admin Panel> Configuration> Security Questions

It says here:  http://docs.mybb.com/1.8/administration/...-questions

"Since the release of MyBB 1.8, Security Questions have been in the core of MyBB. Inspired by -G33K-'s 1.6 Registration Security Question plugin, this feature allows you to configure questions that a visitor may have to answer when registering in your community. To configure the Security Questions, go to
Admin CP > Configuration > Security Questions

When registering, the visitor is given one random question, and the ability to "Refresh" and get a new question. For this reason, it's important to make sure that all of your questions are high-quality and hard for an automated system to figure out the answer to. For example, the default "What does 2 + 2 equal?" question is not hard because most automated systems have figured out how to solve math problems."


So that's missing in my admin panel. Can the code to fix it be inserted somewhere?
Reply
#5
(2015-12-01, 08:35 PM)laie_techie Wrote: The registration question and security question plugins stored the questions / answers in a different db table. On upgrading to MyBB 1.8, I copied from the old table to the new one (it even maintained the correct / total counts). I am not where I can verify the names of the tables.

She is using 1.8.5 so it should be there but the whole security option in her ACP sidebar is missing, she has tried re uploading the whole admin folder but still nothing shows.

Has anyone else had this problem and found a solution?
[Image: sig2.jpg]
Reply
#6
I guess it is because of a broken plugin or anything else, Try to disable all plugins from init.php in inc folder by adding "define("NO_PLUGINS", 1);" without quotes just before the define("TIME_NOW", time()); on line 34 or 35. Hope it ll work to get ACP fixed
[Image: cafaf18ba2.gif]
FileSquid is under development
[Image: trk1]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)