Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved supporting https and http
#1
Not Solved
hi there! So by default MyBB pulls from the board url and the board url states to use http://. before you start it. However, if you have https enabled it doesn't auto adjust so of course all css styles will not load.

I set it to //mysite.com and it works fine. would this have any other effects on the browsing experience?
Reply
#2
Not Solved
I'm not sure I understand what you mean. If you have changed your forum to https and you are asking how to load the sheets over https instead of http you need to edit the board url in your configuration settings and adjust it to https. If you don't mean this please try to explain more.
-Ben

Please do not PM me for support. I am looking to be hired for paid services.

You can view my paid services here.
Reply
#3
Not Solved
Hi Ben!

By default many hosting servers now offer access to both http:// and https:// by default. However with MyBB you can only have one or the other, not both. All the templates you guys have pull from $mybb->settings['bburl'] which in turn is this setting:

Board URL
The url to your forums.
Include the http://. Do NOT include a trailing slash.

That description is misleading. I changed it from http://mysite.com to //mysite.com to support both http/https as that's what you do when you fetch resources. I wanted to know would not having an http: or https: cause issues long term?
Reply
#4
Not Solved
It might cause problems when it's being used as an actual address of the forum, like in email messages.
I would recommend simply running your forum over HTTPS - allowing both protocols can pose a security risk, see https://en.wikipedia.org/wiki/Downgrade_attack.
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply
#5
Not Solved
This should also work: http://community.mybb.com/mods.php?action=view&pid=491
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)