Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved vBulletin 4.2.3 to MyBB 1.8.6... problem attachments (+5000 files)
#1
Not Solved Question 
Hello,

I've converted vBulletin 4.2.3 to MyBB 1.8.6, everything went well less in the part of attachments that in my previous system Vbulletin attachments were not in the database, but in the directory of the server (attachments), also converter has detected more than 5000 attachments to convert and in theory it made the conversion, but no attachment is operational.


Messages with attachments goes thus:

[Imagen: attachment.php?attachmentid=8860&d=1422464145
[attachment=6447]

How can I fix it?, would lose more 5000 attachments.

Thanks!
Reply
#2
Not Solved
Hi,

can you check whether the files were merged? As of 1.8.6 they should be copied to the uploads folder of your mybb installation. Also could you check whether the database table named "mybb_attachments" is empty? And could you take a look at you vb4 forum with which code the attachments are included? Normally it should be "[attach]{id}[/attach]" but apparently something went wrong with that.
Support PMs will be ignored!
Reply
#3
Not Solved
Thanks for responding.

I just checked that the table in the database is well and with all attachments, name and even the id matches that shown on the own message.

Where are attachments saved?
on the bbdd or in any directory?
can you modify this?

Thank you
Reply
#4
Not Solved
^ attachments are saved in uploads sub-folder of the forum folder
Reply
#5
Not Solved
If I put the directory that was used in vBulletin within Uploads with permissions 755, but my question is:

would need to follow keeping the structure of directory I had before in vBulletin??

examples:
/uploads/adjuntos/1/4/2/6/fichero.jpg
/uploads/adjuntos/5/3/1/7/imagen.png

or should I leave the nearly 6000 files in the main directory of uploads?

Thanks! Smile

Hello!,

More info....

I've tried to regenerate thumbnails and it will generate this error:

Warning [2] getimagesize(/home/xxxxxx/public html/uploads/post 0 1263242583.attach): failed to open stream: No such file or directory - Line: 31 - File: inc/functions image.php 5.6.17 PHP (Linux)

Searches the directory/uploads a file called "post 0 1263242583.attach", however the files I have uploaded to that directory with 755 permission called: "1000.attach" and "1000.thumb"

Do I attached a picture of the fields from the table of my database...

   

which should I change?,
should launch some special process?

Thank you.
Reply
#6
Not Solved
Another idea?
Reply
#7
Not Solved
I've never said you should copy anything, just check whether there any files in the uploads.
Support PMs will be ignored!
Reply
#8
Not Solved
I have the same issue. None of the attachments were imported, and the attachment database size of MyBB is less than 200kb while it should been over 100+MB.

EDIT:

By downgrading to MyBB 1.8.11 which matches the merge system to 1.8.11 I was able to import all the attachments. While I'm still currently testing it, the avatars are still failing however. Keep getting:

Invalid user specified for "get_upload_avatar_name"
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)