Thread Rating:
  • 7 Vote(s) - 4.71 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.8] Rin Editor 1.2.4 (Powerd by CKEditor)
This plugin isn't working for me. And any other editor either.

   

My installed plugins list:

Simple Audito Video Embeder (2.0)
Enhanced Account Switcher (2.1.5)
Automention (1.3.2)
Board Announcements Manager (1.0)
DVZ Mentions (0.6)
DVZ Secure Content (1.1.5)
DVZ Shoutbox (2.3.2)
DVZ Stream (2.0.1)
Edit History Log (1.4)
Extended Polls (Pollmanager) (1.5.3)
ezGallery Lite (2.1)
Cytowanie selektywne (1.2.0) (EN: Selectable quoting)
Group Sort (1.1.3)
Login Password Conversion (1.4.1)
MyAlerts (2.0.2)
NewPoints (2.1.1)
OUGC Additional Usergroup Images (1.8)
OUGC Awards (1.8.3)
Page Manager (2.1.2)
Ostrzeżenie o nowych postach (1.0.0) (EN: Warning about new posts)
Post Counter (1.2)
Spoiler MyCode (1.8)
Kolorowe nicki (MyBB 1.8) (1.5.0) (EN: Colorful nicknames)
Tapatalk (4.5.6)
Thank You/Like System (2.1.0)
Thread Redirect (0.2.1)
Statystyki Top (1.0.5)
Trash Bin (1.1.3)
Nieprzeczytane posty (1.9) (EN: Unreaded new posts)
View Groups (1.6)
Reply
(2017-08-31, 09:27 AM)Hewret Wrote: This plugin isn't working for me. And any other editor either.



My installed plugins list:

Simple Audito Video Embeder (2.0)
Enhanced Account Switcher (2.1.5)
Automention (1.3.2)
Board Announcements Manager (1.0)
DVZ Mentions (0.6)
DVZ Secure Content (1.1.5)
DVZ Shoutbox (2.3.2)
DVZ Stream (2.0.1)
Edit History Log (1.4)
Extended Polls (Pollmanager) (1.5.3)
ezGallery Lite (2.1)
Cytowanie selektywne (1.2.0) (EN: Selectable quoting)
Group Sort (1.1.3)
Login Password Conversion (1.4.1)
MyAlerts (2.0.2)
NewPoints (2.1.1)
OUGC Additional Usergroup Images (1.8)
OUGC Awards (1.8.3)
Page Manager (2.1.2)
Ostrzeżenie o nowych postach (1.0.0) (EN: Warning about new posts)
Post Counter (1.2)
Spoiler MyCode (1.8)
Kolorowe nicki (MyBB 1.8) (1.5.0) (EN: Colorful nicknames)
Tapatalk (4.5.6)
Thank You/Like System (2.1.0)
Thread Redirect (0.2.1)
Statystyki Top (1.0.5)
Trash Bin (1.1.3)
Nieprzeczytane posty (1.9) (EN: Unreaded new posts)
View Groups (1.6)

You are having issues with javascript.
You need give acp access to fix your problem, but I do not give this kind of support.
You can contact @.m. to fix your issue.
Reply
Hello, I have this problem too in the console, with the quick_quote and I use Chrome.

[Image: 481ead4c55.png]

Thanks for support Smile.

EDIT: Sorry, now it's fixed.
Reply
I'm wondering about the entire "insert paragraph" thing.
Is there a hotkey for this or.. what can I do to make the down arrow work like any wysiwyg editor is expected to.

For example when quoting it's awful I have to go and click the red arrow or I'm not able to get outside the quote block whatsoever...

EDIT: I think I know what I want - I want CKEditor to add <p></p> at the end of the file no matter what.
From what I gathered it's configured via CKEDITOR.editorConfig.autoParagraph = true;
But unfortunately the config.js of rin doesn't affect anything... any ideas?
Reply
I observed just now that all the images from my forum uploaded on imgur with the "i" button from RinEditor, are not in the account created especialy for this purpose. The API number / client ID is ok and verified and is placed in the plugin settings.
There is a communication problem RinEditor - ImgUr or is my fault ?
Maybe, for store all images in the same place / account must to use another plugin (like ABP Imgur) not Rin Editor?

Thank you,
Reply
(2017-10-06, 10:29 AM)Lyvyoo Wrote: I observed just now that all the images from my forum uploaded on imgur with the "i" button from RinEditor, are not in the account created especialy for this purpose. The API number / client ID is ok and verified  and is placed in the plugin settings.
There is a communication problem RinEditor - ImgUr or is my fault ?
Maybe, for store all images in the same place / account must to use another plugin (like ABP Imgur) not Rin Editor?

Thank you,

Imgur stopped working for me as well..
Something about a header field named Origin being blank instead my site url.
I went to try another account in imgur and apperantely we can't open api request anymore for some reason.
Opened an issue sent me gif and apologized... didn't do anything.
It seems the entire creation process has changed lately.
Something's weird on the imgur side for sure.

Now I'm trying to integrate ckeditor plugins to replace it with little success. (sepcifically one named "imageupload")
Reply
@martec and others - Imgur changed API, maybe some changes are needed Sad
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
(2017-10-06, 08:59 PM)Eldenroot Wrote: @martec and others - Imgur changed API, maybe some changes are needed Sad

They said the API issue is gone but the api registration isn't okay yet...
Perhaps they meant they fixed the oauth2 broken API, try check out your site now.

Honestly I'm using now imageupload plugin for ckeditor (also works with rin ofc).
It's drag & drop and easy and honestly fk imgur they overall gave me really bad impression with the way they handle things.
Maybe later I'll make a tutorial on how to install ckeditor plugins and setup file uploading to there.
Reply
Rin Editor : 0.8.10
MyBB : 1.8.12
PHP : 5.6.31

I have a bug that I think is a RIN Editor bug as I can't replicate on the default editor

In a small number of cases, when a user quotes another member, any text they add (i.e. their post) is omitted when they post.  So any text added after a quote simply disappears.

It only seems to affect posts produced in the source, and I think on a mobile browser (but could be wrong - it's been hard to replicate it).  By default, the RIN Editor shows the source on mobiles; I've changed this and it seems to have fixed the problem.

I could only replicate the error on Opera Mini on Android - all other mobile browsers seemed fine for me, but others reported the issue on iOS & FF




Separate question - I can't seem to get "quick quoting" to work on the theme I am using (Flatty) because I think the template is missing the code.  What do I have to add to make it work?
Reply
@martec - when I wanna write anything and send PM/post reply in my smartphone webbrowser (Google Chrome, Android 8) - text just disappeared and the empty message is sent Sad

Do you plan to release any bug fix soon? I saw an issue reported by Wildcard on your GitHub
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)