Thread Rating:
  • 3 Vote(s) - 4.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.8] Lastposter avatar 3.0.x
#1
Shows avatar on some parts of your forums.

By default MyBB not shows avatar due a several reasons, but this feature is used on most common cms and
boards actually.

Since the first 1.6.x series i work so hard to try to get avatars to forumlist, and threadlist, but with a few years this is a real feature missing on 1.8.x series too.

So this plugin allows you to get avatar on some parts of your forums.

Forum Index.
Show Thread.
Private Messages.
Search.
Portal.
Latest threads (portal and sidebox plugin)

In this parts are common hooks to do, but some parts are taking more code work than others.

List of available features:

1.- Avatars in showthread.
2.- Avatars on index.
3.- Avatars on private messages.
4.- Avatars in portal.
5.- 100% compatible with sidebox plugin.
6.- Compatible 100% with Google SEO plugin.
7.- 100% customizable and easy to cutomize.
8.- Formatted usergroups.
9.- Default avatar for guests.
10.- Mark replied threads.
11.- Thread contributor.
12.- Multi language.
13.- Working on mybb 1.8.x versions without problems. (1.8.0 until last 1.8.11)
14.- Work with child fórums and parent fórums, and all the cryteria for new improvements on latest mybb versión.
15.- Formatted names for usergroups on index.
16.- Modal box for click on avatars, you can choose if disable this or enable it or set on click or onmouseover events.
17.- You can enable or disable all features via plugin configuration.
18.- Link to configuration on plugin enabled.
19.- Avatar for announcements.
20.- 100% w3c validation.
21.- Modal extension for any other plugins.
etc...

In few words, this mods allow you to set avatar and customize it at 100%, allowing to show a nice popup with usefull data of any user who has register account on your forum, but in the case is a guest one, only shows avatar of default MyBB theme.

Let introduce this mod avalable on mods site and my site, and github.

But only use the latest revision sended here because is the most stable and woring version tested on our boards.

Previews:

http://community.mybb.com/uploads/mods/p...717ae7.png

http://community.mybb.com/uploads/mods/p...01f1cf.png

http://community.mybb.com/uploads/mods/p...9c8a42.png

http://community.mybb.com/uploads/mods/p...d220a1.png

http://community.mybb.com/uploads/mods/p...4f2cf3.png

http://community.mybb.com/uploads/mods/p...0f798d.png

Customization:

See this guide

https://github.com/WhiteNeo/lastposter-a.../readme.md

I update this guide on github with info on how to customize on default theme, on others you have to use customized vars and setup at your own, maybe we can provide help for other themes to make it shows more nice.

This mod is 100% customizable and aplicable to all MyBB 1.8.x series themes.

Enjoy it and i set this theme because the latest flp version is for 1.6.x series and this version is woring only on1.8.x series, on 1.6.x series should work but with some core editions, so here they are Last poster avatar version for MyBB.

Download:

http://community.mybb.com/mods.php?action=view&pid=74

EDIT: Up to date, new 2.9 version is recommended to use on all MyBB 1.8.x series.

You have to deactivate actual version, then upload new one and activate, then you can customize it at your own.

I will update guide this weekend for new changes on this version.

The most important patch is for new 1.8.8 and 1.8.9 versions of mybb due core changes and the propertly code to work with that changes.

Change list on fist post of this thread. And as ever guide to customize on github up to date with this version 2.9.

https://github.com/WhiteNeo/lastposter-a.../readme.md

Is the guide of customization for 1.8.9 and previous versions of mybb but ony with default theme.

If you have customized theme, maybe this can serve

https://community.mybb.com/thread-189492...pid1250278

And ther is a FAQ of responses:

User guide customization and vars to review in templates:

https://github.com/WhiteNeo/lastposter-a.../readme.md

Column shows bad and like:

[Image: 687474703a2f2f692e696d6775722e636f6d2f4c...452e706e67]


Follow this steps:

https://community.mybb.com/thread-189492...pid1293568

Other issues like this:

[Image: 68747470733a2f2f696d6167652e70726e747363...772e706e67]

It is caused by a conflict with Style Usernames:

Disable formatted names into avatarep settings or deactivate the other plugin i add a warn for this into my plugin, anyway this is the way to fix it due this plugin adds formated names too like style usernames plugin, this feature was implemented since Lasposter avatar for 1.6.3 into my 1.0 version of this plugin with several bugs of course :p

But this two is the most common issues that i have to fix many times.
The only infinite thing is the universe and human stupidity, but the universe is not for sure

Plugins 1.6.x

Plugins 1.8.x

Reply
#2
i update 2.8.4 > 2.8.5 but no work Forum Index page.
other page work but forum index page wrong wiev profil. i click and show guess avatar.
have problem: {$forum['avatarep']}
[Image: 8f1zjvJ.png]
Reply
#3
More details must be usefull.

Like forum url and if you lnow how to reproduce it.

You can see it working on my forum, if you reproduce error there i can review and fix it asap.

Thanks for your time.

Note: Did you reload cache ?
The only infinite thing is the universe and human stupidity, but the universe is not for sure

Plugins 1.6.x

Plugins 1.8.x

Reply
#4
i make new forum localhost same problem Sad only dont work forum index page.
Reply
#5
Yes i reproducte it and fixed.

https://github.com/WhiteNeo/lastposter-a...18x-series

Problem was about Google SEO, well i use Google SEO, so avatar works fine on all users who use Google SEO, but when you use urls from MyBB then error appear and there are no id for user so there are missing data, nice catch .
I catch it thanks to your image, i test on a clean board without any plugin and done !!!

Another error was id for announcements do not catch and username was not taken. But i fixed on github repo, i reccomend you to report all issues here and i fix everyone on github repo and when all is ready then i upload the latest revision with all fixed.

Thanks in advance. This time i catch error and fix it due i reproduce it, sometimes i can no do nothing due i can not reproduce it.

Thanks to you, test the latest github repo and tell me if you catch or find some other issue for i can fix it ASAP.
The only infinite thing is the universe and human stupidity, but the universe is not for sure

Plugins 1.6.x

Plugins 1.8.x

Reply
#6
oke i have updated everything, and guess what my forum is bugged thanks to your plugin Sad

i have added all of the codes from your tutorial and still the problems.


[Image: AvA0fmK.png]

[Image: Z0Zyops.png]
do you see at the last image, my topic name is above the image, somehow your tutorial is not working.

please help me to fix this problem!
i can make for you a account that only can use the templates area!

cause our design is still under construction and not availible for public.
Reply
#7
Yeah do it, every style has their own style, so you have to make some changes, only on deault and deault ones based works fine in others you have to do manually changes.

Make me an account and send me details next weekend right now i have no pc, due it's broken, so i have to buy a new one, i you tell me about this before i have one o some friend to work o paid plugins, but right now i have nothing i try to get one in this next days because i have to finish some details on my plugins, so i i can i check it out when i can, it is an easy task to do i think i can do it on a few minutes, when i got the account i do the changes, take in mind every style has their own stylesheets and templates so i work it only on the theme used by deault or the theme o the previews on others you have to do the same or similar, it is not a problem o plugin or anything it's a problem with your used themes due designers changes all and manytimes broken himselfs the right codes and then blum all goes to hell technically.

So you have to get me details and then i can fix it.

See yah !!!

wow now i can see our forum is a very heavy site lol...

[Image: erdis3.png]
The only infinite thing is the universe and human stupidity, but the universe is not for sure

Plugins 1.6.x

Plugins 1.8.x

Reply
#8
@Dark Neo I'm facing similar issue as Wazzyl, take a look:

https://extrasalty.eu

name shows up but no avatar on main site

I think we're missing some template (or kinda incomplete) here :x


EDIT:

Ok, i found out that in readmefile You attached to the plugin You got some outdated code,

forumbit_depth2_forum_lastpost from github:

<table border="0">
  <tr>
    <td width="20%" align="left" valign="middle">{$forum['avatarep']}<span class="smalltext"></span></td>
    <td width="80%" align="left" valign="top">
<span class="smalltext">
<a href="{$lastpost_link}" title="{$full_lastpost_subject}"><strong>{$lastpost_subject}</strong></a>
<br />{$lastpost_date} {$lastpost_time}<br />{$lastpost_profilelink}</span>
   </td>
  </tr>
</table>

But the avatar is oddly "High", not centered there, could You tell me why?


EDIT2:

Ok, i figured it out, css stuff You gave in the readme was also outdated. After updating to the github one everything works like a charm.
Please update Your package here Wink

Awesome work!
Reply
#9
@Eska yes i mentioned that when some user tell me about some problem and now when i go to the site of thé user i know the error was on user who wont use Google SEO.

By the way all stuff is already done on github repo and i test on my forums so as far as i know it works, but i say users to report issues or any to fix it before upload the latest revision here.

I fix it all that i can reproduce, so i really apreciate if many users test it and report or contribute to maje a better mod and release and up to date.

I recommend if you are not using Google SEO or anyway to up to date with github repo i update contents and file here ASAP.
The only infinite thing is the universe and human stupidity, but the universe is not for sure

Plugins 1.6.x

Plugins 1.8.x

Reply
#10
have you fixed this dark?
look same problem with wazzyl
My Post #60
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)