Jump to the post that solved this thread.
Solved: 4 Years, 11 Months ago Can't select "Full Text" for Search
#1
Solved: 4 Years, 11 Months ago
I've recently installed a clean installation of MyBB and have come across a slight annoyance with the search system.

For whatever reason, I am unable to select "Full Text" for the search system in the drop down menu.
[Image: mXeQoCn.png]

I am using MySQL 5.7.11, my database and tables are all InnoDB and my collation is utf8mb4_general_ci for all tables and fields.

Everything is working perfectly on my forum, but I'd like to be able to use "Full Text" instead of "Standard". Can anyone provide some help to get this feature working?
Reply
#2
Solved: 4 Years, 11 Months ago
Bumping for visibility
Reply
#3
Solved: 4 Years, 11 Months ago
not sure if full text indexes are available with InnoDB
if they are not available then full text search option is not available at MyBB search settings

reference : settings.xml#L1851-L1852
Reply
#4
Solved: 4 Years, 11 Months ago
what version appear in ACP?

[Image: 1l5qGII.png]

if appear less than 5.6, so Full Text not will appear in mybb.
if you have absolutely sure that using version more than 5.6 you can edit this line in core file https://github.com/mybb/mybb/blob/featur....php#L1178
Reply
#5
Solved: 4 Years, 11 Months ago
Looks like that's why I can't select it, MySQLi is reporting an incorrect version for some reason?

I am using MariaDB 10.1.12 but for whatever reason it's reporting as "MySQLi 5.5.5" in the MyBB Admin Control Panel.

Anyone know what's up with that? Probably an unrelated MyBB thing but I'm positive I'm running the latest release of MariaDB/MySQL.

Thanks for the help though, I've gone ahead and edited the core file and changed it so I could select it and it works fine.
Reply
#6
Solved: 4 Years, 11 Months ago
(2016-03-21, 10:25 AM)Puremin0rez Wrote: Looks like that's why I can't select it, MySQLi is reporting an incorrect version for some reason?

I am using MariaDB 10.1.12 but for whatever reason it's reporting as "MySQLi 5.5.5" in the MyBB Admin Control Panel.

Anyone know what's up with that? Probably an unrelated MyBB thing but I'm positive I'm running the latest release of MariaDB/MySQL.

Thanks for the help though, I've gone ahead and edited the core file and changed it so I could select it and it works fine.

this happen why you using php-mysqlnd, and php-mysqlnd has issue in determinate correct version of MariaDB. php-mysql get correct version of MariaDB, but not recomended http://serverfault.com/a/400442
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)