Not Solved install issues, file permissions
#1
Not Solved
So i am no expert or noob in linux. i know how to chmod and everything. 

I am having trouble with the setup. I have ./inc/config.php and ./cache/ both chmod to 666 (even tried 777) and still it doenst pick them up as being correct. 

I have went as far as rebooting the server. 



Vmware running CentOS 7 both latest release. 

SCREENSHOT LINK
https://gyazo.com/02e9e24554ce3b51368f9212199d82e2





*****first post, newb here...blah blah forum******
Reply
#2
Not Solved
Can you tell how you are doing chmod, my suggestion is if you have a Putty or scp than use this command to change permissions :-
chmod -R 777 cache
chmod 777 inc/config.php

Regards
WallBB
Reply
#3
Not Solved
(2016-03-24, 03:02 PM)WallBB Wrote: Can you tell how you are doing chmod, my suggestion is if you have a Putty or scp than use this command to change permissions :-
chmod -R 777 cache
chmod 777 inc/config.php

Regards
WallBB

That is what i originally did. i have my forum in /var/www/html/forum/. Again it is a fresh LAMP stack. 

I did chmod on the entire directory.

sudo chmod -R 777 /var/www/html/forum/*

I then rebooted the server, and still the issue persists. I can only imagine that this issue is related to the actual application. I dare say that i nearly should make the whole file system full permissions. Though i am quite sure that wont fix the issue nor will it be a smart move.

It is also worth mentioning. I edited the config.php file manually and added a 1 to it. This changed the font size of the Requirements Check page. So it is clearly reading my config file.

I also created a blank config file manually and it also did not work. chmod to 777 after first try and still no avail.

I have been able to re-create this issue. I followed the exact things on the documentation and was unable to get past the exact point. I even used your own chown commands to sum it up

Can some one else please give this a shot? Start from scratch with it all.

(2016-03-24, 03:46 PM)Wdrussell1 Wrote:
(2016-03-24, 03:02 PM)WallBB Wrote: Can you tell how you are doing chmod, my suggestion is if you have a Putty or scp than use this command to change permissions :-
chmod -R 777 cache
chmod 777 inc/config.php

Regards
WallBB

That is what i originally did. i have my forum in /var/www/html/forum/. Again it is a fresh LAMP stack. 

I did chmod on the entire directory.

sudo chmod -R 777 /var/www/html/forum/*

I then rebooted the server, and still the issue persists. I can only imagine that this issue is related to the actual application. I dare say that i nearly should make the whole file system full permissions. Though i am quite sure that wont fix the issue nor will it be a smart move.

It is also worth mentioning. I edited the config.php file manually and added a 1 to it. This changed the font size of the Requirements Check page. So it is clearly reading my config file.

I also created a blank config file manually and it also did not work. chmod to 777 after first try and still no avail.

I have been able to re-create this issue. I followed the exact things on the documentation and was unable to get past the exact point. I even used your own chown commands to sum it up

Can some one else please give this a shot? Start from scratch with it all.
I finally found the issue....

The problem was that I needed to modify the selinux configuration appropriately. For others encountering the same problem: if selinux is enforced, you need to do (single line command)


chcon -t httpd_sys_rw_content_t cache cache/themes uploads uploads/avatars admin/backups inc/config.php inc/settings.php inc/languages/english/*.php inc/languages/english/admin/*.php
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)