Jump to the post that solved this thread.
Solved: 5 Years, 9 Months ago Error when following installation instructions
#1
Solved: 5 Years, 9 Months ago Sad 
I am trying to install MyBB on a Centos Linux system. I am a Windows person, so this may be difficult for me. Sad

I'm following the instructions on page http://docs.mybb.com/1.8/install/.

I copied the files from the Upload dir. I ran all the chmod commands listed using a remote shell cd to the MyBB dir.

I then pointed my browser to the Install dir (MyBB/install) per the instructions.

The result is error 403 (Attempt to view a protected file or directory).

My guess is that the owner or mod is incorrect. Maybe the CoreFTP program didn't set the mods to what MyBB wants and the installation instructions are incomplete in this situation (if this is true, then someone should edit the installation instructions, or better, to include a command file to set all the mods to what is needed--manual operations are not as reliable).

The info for dir MyBB is: drwxr-xr-x
The info for dir install is: drwxr-xr-x
The owner is the owner of the remote account (this comes from my CoreFTP connection parameters)

Let me know if you need more info.

David
Reply
#2
Solved: 5 Years, 9 Months ago
Make sure there is no .htaccess restriction inside your root folder, which i highly doubt. Check my sig Smile
Reply
#3
Solved: 5 Years, 9 Months ago Question 
I don't know what "check my sig" means, but starting from /, there is only one .htaccess file. It is in the parent dir of the parent dir of the MyBB dir and has this content:

# Access ver=2/16/06
DirectoryIndex home.php index.html
Options -Indexes
Options FollowSymLinks
ErrorDocument 400 /error.php
ErrorDocument 401 /error.php
ErrorDocument 403 /error.php
ErrorDocument 404 /error.php
ErrorDocument 500 /error.php

When I rename this file, I am able to run the Install Wizard page, so this file must be creating the Error 403 condition.

Can someone explain how this works, and how I can fix the .htaccess file? I want MyBB to be found within my web pages.

Thanks
Reply
#4
Solved: 5 Years, 9 Months ago
Sig == Signature , for the free mybb installation service.

As for the .htaccess code, i don't see anything which would block installation.
Try deleting .htaccess file and install mybb else check my free service and i will do installation for you.
Reply
#5
Solved: 5 Years, 9 Months ago
Quote:DirectoryIndex home.php index.html
when we type a directory url, it first tries to get home.php file.
if home.php doesn't exist then looks for index.html file.

MyBB uses index.php file for the index (both for installation & loading forum)
Reply
#6
Solved: 5 Years, 9 Months ago
I can see how DirectoryIndex might be a problem if it made Apache select the wrong file. But exactly how is this working for MyBB? How does this cause the Error 403? I want to understand this.
Reply
#7
Solved: 5 Years, 9 Months ago
So what happens when you go to MyBB/install/index.php? Have you checked your Apache logs?
Reply
#8
Solved: 5 Years, 9 Months ago
Sorry, somehow didn't think of that. The error is: "Cannot serve directory /home/learnnsr/public_html/forum/English/install/: No matching DirectoryIndex (home.php,index.html) found, and server-generated directory index forbidden by Options directive."

I'm understanding this a little better, but, sorry, I don't see why the MyBB installation should rely on a DirectoryIndex. Why doesn't it specify a filename for the Install Wizard, or else provide a proper .htaccess file containing the required DirectoryIndex directive?

This way, I have to change how my website uses DirectoryIndex, which, sorry, seems unnecessarily intrusive.
Reply
#9
Solved: 5 Years, 9 Months ago
Your DirectoryIndex is with a part of your apache configuration. Apache doesn't ship with PHP and sometimes requires you to manually add the DirectoryIndex.

DirectoryIndex is basically apache saying "If no file is specified, I'm going to try and find one of the files in DirectoryIndex" but obviously home.php and index.html aren't there, so we need to add index.php.

Check whether your DirectoryIndex is in your httpd.conf file and add index.php
Reply
#10
Solved: 5 Years, 9 Months ago Smile 
(2016-04-11, 01:13 PM)nth Wrote: Thank you for your solution.

My revised directive is:

DirectoryIndex home.php index.php index.html

This works for Install Wizard and shouldn't interfere with any other parent or cousin pages.

Thanks for everyone's help.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)