Not Solved Install Script Thinks I'm on A Older Version
Not Solved
I recently just noticed the update to MyBB and decided to update ASAP. I had forgotten the process but I checked the blog post and went through the Upgrade documentation. I followed the instructions up until the point of using the .domain/install page to push the update.

For some strange reason, the install page thinks I'm running on an older version of MyBB than what the site is actually on. 

Here's a picture of what the dashboard says:
[Image: mybbdashboard.png]

And the install page claims:
[Image: mybbinstallscreen.png]

This left me scratching my head and I'm definitely not going to risk "updating" if it thinks I'm running an older version.
Not Solved
assuming that you have followed all steps of upgrading
run file verification tool available at tools & maintenance section of forum admin panel.
what does it report ?
Not Solved
When I ran the tool I got this long list of results:

File	Status
secpanel/inc/class_table.php	Changed
secpanel/inc/functions_themes.php	Changed
secpanel/inc/functions.php	Changed
secpanel/inc/class_page.php	Changed
secpanel/inc/functions_view_manager.php	Changed
secpanel/inc/class_form.php	Changed
secpanel/modules/user/module_meta.php	Changed
secpanel/modules/user/group_promotions.php	Changed
secpanel/modules/user/groups.php	Changed
secpanel/modules/user/users.php	Changed
secpanel/modules/user/banning.php	Changed
secpanel/modules/style/module_meta.php	Changed
secpanel/modules/style/templates.php	Changed
secpanel/modules/forum/module_meta.php	Changed
secpanel/modules/forum/attachments.php	Changed
secpanel/modules/forum/management.php	Changed
secpanel/modules/forum/announcements.php	Changed
secpanel/modules/home/module_meta.php	Changed
secpanel/modules/home/credits.php	Changed
secpanel/modules/home/preferences.php	Changed
secpanel/modules/config/thread_prefixes.php	Changed
secpanel/modules/config/module_meta.php	Changed
secpanel/modules/config/plugins.php	Changed
secpanel/modules/config/profile_fields.php	Changed
secpanel/modules/config/post_icons.php	Changed
secpanel/modules/config/calendars.php	Changed
secpanel/modules/config/smilies.php	Changed
secpanel/modules/config/mycode.php	Changed
secpanel/modules/config/help_documents.php	Changed
secpanel/modules/tools/module_meta.php	Changed
secpanel/modules/tools/recount_rebuild.php	Changed
secpanel/modules/tools/adminlog.php	Changed
secpanel/modules/tools/backupdb.php	Changed
secpanel/modules/tools/mailerrors.php	Changed
secpanel/modules/tools/statistics.php	Changed
secpanel/modules/tools/tasks.php	Changed
EDIT: There does exist the possibility that the last update (1.8.6) was improperly done or applied. I definitely would not rule that out. In such a case, what could be done to upgrade to 1.8.7 without losing data?
Not Solved
looks like you forgot that you have renamed admin folder
and upgrade related files were copied to old admin folder !
Not Solved
Whoops! What a mess up on my part.. What exactly could I do to fix this though?
Not Solved
find files & sub-folders uploaded to ~/admin folder and move them to your renamed admin folder

if above doesn't help then you may PM me temporary access to your forum admin panel & files (FTP) to check
Not Solved
Pm'ed, thanks for all your help!

Forum Jump:

Users browsing this thread: 1 Guest(s)