Jump to the post that solved this thread.
Solved: 6 Years, 1 Month, 1 Week ago Help a brazilian noob upgrading MyBB 1.8.6 to 1.8.7
#1
Solved: 6 Years, 1 Month, 1 Week ago
Hey guys!

Sorry for bother all you, but im having a issue here and after reading carefully all the instructions, and blogs, and etc., im still loosing my mind.

Note: This is my first forum, and im trying to get better at adm stuff, but, sometimes this is beyond my capacities.

I downloaded today the "Changed Files Packs" (after all, im using 1.8.6), unziped in my computer and uploaded the files in the respective directories using my FTP. All good here.

But, when im going to install (~/forum/install) the upgrade tell me that im "upgrading my old version TO 1.8.6" - dont shows nothing about 1.8.7).

So... What i have to do?

Just like a noob, i installed the "upgrade" but, my dashboard still saying that i have 1.8.6 version.

My Forum link is: www.politz.com.br/forum

Please, help me.

This is my file verification log:


Quote:polls.php Changed
search.php Changed
sendthread.php Changed
archive/index.php Changed
modcp.php Changed
admin/modules/user/groups.php Changed
admin/modules/user/users.php Changed
admin/modules/user/admin_permissions.php Changed
admin/modules/user/banning.php Changed
admin/modules/style/themes.php Changed
admin/modules/tools/recount_rebuild.php Changed
admin/modules/tools/backupdb.php Changed
admin/modules/tools/modlog.php Changed
admin/modules/tools/system_health.php Changed
admin/modules/tools/adminlog.php Changed
admin/modules/tools/spamlog.php Changed
admin/modules/forum/management.php Changed
admin/index.php Changed
admin/inc/class_form.php Changed
admin/inc/functions.php Changed
admin/inc/class_page.php Changed
forumdisplay.php Changed
usercp2.php Changed
newreply.php Changed
inc/functions.php Changed
warnings.php Changed
contact.php Changed
member.php Changed
editpost.php Changed
private.php Changed
printthread.php Changed
usercp.php Changed
ratethread.php Changed
showthread.php Changed
calendar.php Changed
xmlhttp.php Changed
reputation.php Changed
global.php Changed
jscripts/inline_moderation.js Changed
jscripts/general.js Changed
jscripts/select2/select2.css Changed
misc.php Changed
newthread.php Changed
managegroup.php Changed
Reply
#2
Solved: 6 Years, 1 Month, 1 Week ago
Read this tutorial on upgrading MyBB, follow steps by steps.
http://docs.mybb.com/1.8/install/upgrade/
Download the upgrade pacakage from here
http://blog.mybb.com/2016/03/11/mybb-1-8...7-release/
Reply
#3
Solved: 6 Years, 1 Month, 1 Week ago
looks like some of old version files were not replaced by the new version files.
can you upload the files again & run upgrade script (put forum offline & take
database backup before upgrading)
Reply
#4
Solved: 6 Years, 1 Month, 1 Week ago
Hey guys, thanks for replying me. Is hard to found here in Brazil a good community to help people. Trust me on this. For some kind of pride or something brazilian-italian-german i never ask for support, i dont like to annoying other people with my problems. Its only on my last shot! And very sorry about my very bad english...

(2016-04-19, 02:46 AM)WallBB Wrote: Read this tutorial on upgrading MyBB, follow steps by steps.
http://docs.mybb.com/1.8/install/upgrade/
Download the upgrade pacakage from here
http://blog.mybb.com/2016/03/11/mybb-1-8...7-release/

Hello you again! I sent you an MP in the morning for your theme support. Your login still active.
I read all the tutorials many and many times but did not work. So... See what i did:

(2016-04-19, 02:46 AM).m. Wrote: looks like some of old version files were not replaced by the new version files.
can you upload the files again & run upgrade script (put forum offline & take
database backup before upgrading)

M, you are like the M from 007 from helping this community or some kind of Support Genius, you deserve some recommendation (or money) for all this free help. I spend many hours reading all the Forum and your job done here is great, very awesome!! My congrats for you!!

Guys, what i did is:
- Uploaded many and many times the "Upgrade Package", but, did not work. I dont know why. Unziped, uploaded again, downloaded again in this almost infinite loop.

So, im noobing around my Forum and uploaded the HOLE FULL INSTALLATION PACKAGE (not good?) in my forum dir and............. IT WORKED! I run the install link (forum/install) and upgraded like a software, very nice, very easy. Dont loose nothing (include some noobie templates modifications), my tests posts, my configurations, its all here! The only thing i did is reinstall the plugins to work properly. HOW NICE IS THAT?

I dont know if this maybe get me some securities issues in my forum, or bugs whats so ever (not seeing), but... It worked. You guys recommend this kind of brazilian newbie stuff? Or its better to delete all the content in my forum dir and do some full clean installation again?
Reply
#5
Solved: 6 Years, 1 Month, 1 Week ago
^ if upgrade from changed files pack is not working (due to some odd reason)
we do recommend to try upgrading from the full package of the new version.
no harm is done. one has to follow the upgrading steps just like you did Smile
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)